Opened 10 years ago

Closed 10 years ago

#1904 closed bug (Invalid)

WEBUI doesn't connect to deluge-daemon after refresh (F5)

Reported by: shinger Owned by: damoxc
Priority: major Milestone: 1.3.4
Component: Web UI Version: 1.3.2
Keywords: Cc:

Description

After reboot the possibility to connect Deluge: Web UI tot Deluge-Daemon is gone if you press F5 or just refresh button on your browser.

The only way to see the torrents, is to open GTK and connect to the deluge-daemon.

Change History (6)

comment:1 in reply to: ↑ description Changed 10 years ago by shinger

Replying to shinger:

After reboot the possibility to connect Deluge: Web UI tot Deluge-Daemon is gone if you press F5 or just refresh button on your browser.

The only way to see the torrents, is to open GTK and connect to the deluge-daemon.

The problem consists in 1.3.2 and 1.3.3. But did not have any problems when using 1.3.1

comment:2 Changed 10 years ago by shinger

I've tried to downgrade it to version 1.3.1 and strangely the problem also accoured on that version. This takes away that the problem is within 1.3.2 or 1.3.3. I think that the problem may be in some packages that has been updated/upgraded. Packages that deluge depens on. It also is possible that its the browsers fault, but i doubt that. I've tested it with Latest firefox, chrome, android (2.3.3) default browser and even with IE 9.

comment:3 follow-up: Changed 10 years ago by damoxc

I don't really understand what you mean by this? Are you saying that on a fresh start the daemon won't accept a connection from the web interface? Screenshots or deluge logs would be a great help. Thanks!

comment:4 in reply to: ↑ 3 Changed 10 years ago by shinger

Replying to damoxc:

I don't really understand what you mean by this? Are you saying that on a fresh start the daemon won't accept a connection from the web interface? Screenshots or deluge logs would be a great help. Thanks!

To install Deluge headless ive used this tutorial: http://ubuntuforums.org/showthread.php?t=1433783

LOG:(Deluged.log)

[WARNING ] 16:33:17 authmanager:135 Your auth entry for deluge contains no auth level, using AUTH_LEVEL_DEFAULT(5)..
[WARNING ] 16:33:17 config:361 Unable to open config file /var/lib/deluge/pieces.conf: [Errno 2] No such file or directory: '/var/lib/deluge/pieces.conf'

DEBUG:

INFO    ] 17:08:59 daemon:129 Deluge daemon 1.3.3
[DEBUG   ] 17:08:59 daemon:130 options: {'profile': False, 'loglevel': 'debug', 'quiet': False, 'ui_interface': None, 'interface': None, 'logfile': 'text1.txt', 'config': None, 'port': None, 'pidfile': None, 'donot': False}
[DEBUG   ] 17:08:59 daemon:131 args: []
[DEBUG   ] 17:08:59 core:76 Core init..
[INFO    ] 17:08:59 core:80 Starting libtorrent 0.15.8.0 session..
[WARNING ] 17:08:59 core:169 Failed to load lt state: [Errno 2] No such file or directory: '/home/shinger/.config/deluge/session.state'
[DEBUG   ] 17:08:59 configmanager:111 Getting config 'core.conf'
[DEBUG   ] 17:08:59 config:197 Setting 'info_sent' to 0.0 of <type 'float'>
[DEBUG   ] 17:08:59 config:197 Setting 'lsd' to True of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'send_info' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'move_completed_path' to /home/shinger of <type 'str'>
[DEBUG   ] 17:08:59 config:197 Setting 'enc_in_policy' to 1 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'queue_new_to_top' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'ignore_limits_on_local_network' to True of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'rate_limit_ip_overhead' to True of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'daemon_port' to 58846 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'torrentfiles_location' to /home/shinger of <type 'str'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_active_limit' to 8 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'utpex' to True of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_active_downloading' to 3 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_active_seeding' to 5 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'allow_remote' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_half_open_connections' to 50 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'download_location' to /home/shinger of <type 'str'>
[DEBUG   ] 17:08:59 config:197 Setting 'compact_allocation' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_upload_speed' to -1.0 of <type 'float'>
[DEBUG   ] 17:08:59 config:197 Setting 'cache_expiry' to 60 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'prioritize_first_last_pieces' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'auto_managed' to True of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'enc_level' to 2 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_connections_per_second' to 20 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'dont_count_slow_torrents' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'random_outgoing_ports' to True of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'dht' to True of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'new_release_check' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'enc_out_policy' to 1 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_upload_slots_global' to 4 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'seed_time_limit' to 180 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'cache_size' to 512 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'share_ratio_limit' to 2.0 of <type 'float'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_download_speed' to -1.0 of <type 'float'>
[DEBUG   ] 17:08:59 config:197 Setting 'geoip_db_location' to /usr/share/GeoIP/GeoIP.dat of <type 'str'>
[DEBUG   ] 17:08:59 config:197 Setting 'natpmp' to True of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'stop_seed_at_ratio' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'peer_tos' to 0x00 of <type 'str'>
[DEBUG   ] 17:08:59 config:197 Setting 'listen_interface' to  of <type 'str'>
[DEBUG   ] 17:08:59 config:197 Setting 'upnp' to True of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_download_speed_per_torrent' to -1 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'outgoing_ports' to [0, 0] of <type 'list'>
[DEBUG   ] 17:08:59 config:197 Setting 'enabled_plugins' to [] of <type 'list'>
[DEBUG   ] 17:08:59 config:197 Setting 'random_port' to True of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'autoadd_enable' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_connections_global' to 200 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'enc_prefer_rc4' to True of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'listen_ports' to [6881, 6891] of <type 'list'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_upload_slots_per_torrent' to -1 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'stop_seed_ratio' to 2.0 of <type 'float'>
[DEBUG   ] 17:08:59 config:197 Setting 'seed_time_ratio_limit' to 7.0 of <type 'float'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_upload_speed_per_torrent' to -1 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'copy_torrent_file' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'del_copy_torrent_file' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'move_completed' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'proxies' to {'peer': {'username': '', 'password': '', 'hostname': '', 'type': 0, 'port': 8080}, 'web_seed': {'username': '', 'password': '', 'hostname': '', 'type': 0, 'port': 8080}, 'tracker': {'username': '', 'password': '', 'hostname': '', 'type': 0, 'port': 8080}, 'dht': {'username': '', 'password': '', 'hostname': '', 'type': 0, 'port': 8080}} of <type 'dict'>
[DEBUG   ] 17:08:59 config:197 Setting 'add_paused' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'max_connections_per_torrent' to -1 of <type 'int'>
[DEBUG   ] 17:08:59 config:197 Setting 'remove_seed_at_ratio' to False of <type 'bool'>
[DEBUG   ] 17:08:59 config:197 Setting 'autoadd_location' to /home/shinger of <type 'str'>
[DEBUG   ] 17:08:59 config:197 Setting 'plugins_location' to /home/shinger/.config/deluge/plugins of <type 'str'>
[DEBUG   ] 17:08:59 config:391 Config /home/shinger/.config/deluge/core.conf version: 1.1 loaded: {'info_sent': 0.0, 'lsd': True, 'max_download_speed': -1.0, 'send_info': False, 'natpmp': True, 'move_completed_path': '/home/shinger', 'peer_tos': '0x00', 'enc_in_policy': 1, 'queue_new_to_top': False, 'ignore_limits_on_local_network': True, 'rate_limit_ip_overhead': True, 'daemon_port': 58846, 'torrentfiles_location': '/home/shinger', 'max_active_limit': 8, 'geoip_db_location': '/usr/share/GeoIP/GeoIP.dat', 'upnp': True, 'utpex': True, 'max_active_downloading': 3, 'max_active_seeding': 5, 'allow_remote': False, 'outgoing_ports': [0, 0], 'enabled_plugins': [], 'max_half_open_connections': 50, 'download_location': '/home/shinger', 'compact_allocation': False, 'max_upload_speed': -1.0, 'plugins_location': u'/home/shinger/.config/deluge/plugins', 'max_connections_global': 200, 'enc_prefer_rc4': True, 'cache_expiry': 60, 'dht': True, 'stop_seed_at_ratio': False, 'stop_seed_ratio': 2.0, 'max_download_speed_per_torrent': -1, 'prioritize_first_last_pieces': False, 'max_upload_speed_per_torrent': -1, 'auto_managed': True, 'enc_level': 2, 'copy_torrent_file': False, 'max_connections_per_second': 20, 'listen_ports': [6881, 6891], 'max_connections_per_torrent': 200, 'del_copy_torrent_file': False, 'move_completed': False, 'autoadd_enable': False, 'proxies': {'peer': {'username': '', 'password': '', 'hostname': '', 'type': 0, 'port': 8080}, 'web_seed': {'username': '', 'password': '', 'hostname': '', 'type': 0, 'port': 8080}, 'tracker': {'username': '', 'password': '', 'hostname': '', 'type': 0, 'port': 8080}, 'dht': {'username': '', 'password': '', 'hostname': '', 'type': 0, 'port': 8080}}, 'dont_count_slow_torrents': False, 'add_paused': False, 'random_outgoing_ports': True, 'max_upload_slots_per_torrent': -1, 'new_release_check': False, 'enc_out_policy': 1, 'seed_time_ratio_limit': 7.0, 'remove_seed_at_ratio': False, 'autoadd_location': u'/home/shinger', 'max_upload_slots_global': 4, 'seed_time_limit': 180, 'cache_size': 512, 'share_ratio_limit': 2.0, 'random_port': True, 'listen_interface': ''}
[DEBUG   ] 17:08:59 alertmanager:53 AlertManager initialized..
[DEBUG   ] 17:08:59 pluginmanagerbase:65 Plugin manager init..
[DEBUG   ] 17:08:59 configmanager:111 Getting config 'core.conf'
[DEBUG   ] 17:08:59 pluginmanagerbase:124 Found plugin: AutoAdd 1.03 at /usr/share/pyshared/deluge/plugins/AutoAdd-1.03-py2.6.egg
[DEBUG   ] 17:08:59 pluginmanagerbase:124 Found plugin: Execute 1.2 at /usr/share/pyshared/deluge/plugins/Execute-1.2-py2.6.egg
[DEBUG   ] 17:08:59 pluginmanagerbase:124 Found plugin: Stats 0.3.2 at /home/shinger/.config/deluge/plugins/Stats-0.3.2-py2.6.egg
[DEBUG   ] 17:08:59 pluginmanagerbase:124 Found plugin: Blocklist 1.2 at /usr/share/pyshared/deluge/plugins/Blocklist-1.2-py2.6.egg
[DEBUG   ] 17:08:59 pluginmanagerbase:124 Found plugin: Extractor 0.1 at /usr/share/pyshared/deluge/plugins/Extractor-0.1-py2.6.egg
[DEBUG   ] 17:08:59 pluginmanagerbase:124 Found plugin: Label 0.1 at /usr/share/pyshared/deluge/plugins/Label-0.1-py2.6.egg
[DEBUG   ] 17:08:59 pluginmanagerbase:124 Found plugin: Notifications 0.1 at /usr/share/pyshared/deluge/plugins/Notifications-0.1-py2.6.egg
[DEBUG   ] 17:08:59 pluginmanagerbase:124 Found plugin: WebUi 0.1 at /usr/share/pyshared/deluge/plugins/WebUi-0.1-py2.6.egg
[DEBUG   ] 17:08:59 pluginmanagerbase:124 Found plugin: Scheduler 0.2 at /usr/share/pyshared/deluge/plugins/Scheduler-0.2-py2.6.egg
[DEBUG   ] 17:08:59 torrentmanager:127 TorrentManager init..
[DEBUG   ] 17:08:59 configmanager:111 Getting config 'core.conf'
[DEBUG   ] 17:08:59 config:304 Registering function for max_connections_per_torrent key..
[DEBUG   ] 17:08:59 torrentmanager:833 max_connections_per_torrent set to 200..
[DEBUG   ] 17:08:59 config:304 Registering function for max_upload_slots_per_torrent key..
[DEBUG   ] 17:08:59 torrentmanager:839 max_upload_slots_per_torrent set to -1..
[DEBUG   ] 17:08:59 config:304 Registering function for max_upload_speed_per_torrent key..
[DEBUG   ] 17:08:59 torrentmanager:844 max_upload_speed_per_torrent set to -1..
[DEBUG   ] 17:08:59 config:304 Registering function for max_download_speed_per_torrent key..
[DEBUG   ] 17:08:59 torrentmanager:849 max_download_speed_per_torrent set to -1..
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert torrent_finished_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert torrent_paused_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert torrent_checked_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert tracker_reply_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert tracker_announce_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert tracker_warning_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert tracker_error_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert storage_moved_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert torrent_resumed_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert state_changed_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert save_resume_data_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert save_resume_data_failed_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert file_renamed_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert metadata_received_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert file_error_alert
[DEBUG   ] 17:08:59 alertmanager:96 Registered handler for alert file_completed_alert
[DEBUG   ] 17:08:59 filtermanager:105 FilterManager init..
[DEBUG   ] 17:08:59 configmanager:111 Getting config 'core.conf'
[DEBUG   ] 17:08:59 config:304 Registering function for autoadd_enable key..
[DEBUG   ] 17:08:59 autoadd:124 _on_autoadd_enable
[DEBUG   ] 17:08:59 config:304 Registering function for autoadd_location key..
[DEBUG   ] 17:08:59 autoadd:131 _on_autoadd_location
[DEBUG   ] 17:08:59 configmanager:111 Getting config 'core.conf'
[INFO    ] 17:08:59 rpcserver:366 Starting DelugeRPC server localhost:58846
[INFO    ] 17:08:59 rpcserver:374 Daemon already running or port not available..
[ERROR   ] 17:08:59 rpcserver:375 Couldn't listen on localhost:58846: [Errno 98] Address already in use.

comment:5 Changed 10 years ago by shinger

Ive also made a printscreen. In the printscreen you see that its connected but i dont see any of my torrents. If i reconnect the deluged the torrents appear but they dont use ajax to refresh.

http://shinger.homelinux.com/Deluge.png

comment:6 Changed 10 years ago by damoxc

  • Resolution set to invalid
  • Status changed from new to closed

Hi, this looks like a configuration error, not a bug. One daemon is using /var/lib/deluge and one is using /home/shinger/.config/deluge. Check your configuration, make sure you aren't spawning the webui and daemon using different configuration directories.

Note: See TracTickets for help on using tickets.