Opened 7 years ago

Closed 6 years ago

Last modified 10 months ago

#1951 closed bug (Fixed)

'git master' does not load plugins in Ubuntu

Reported by: firefox Owned by:
Priority: blocker Milestone: 2.x
Component: Plugin Version: master (git)
Keywords: Cc: s0undt3ch

Description

after upgrading to oneiric seems that the git master version does not load plugins. i will attach a traceback

Attachments (1)

deluge.bug (3.2 KB) - added by firefox 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by firefox

comment:1 Changed 6 years ago by Cas

  • Cc s0undt3ch added

ok this is a very strange issue with a very hacky workaround for now:

Copy:

 deluge/plugins/init.py 
 deluge/plugins/pluginbase.py 

To:

 deluge/plugins/Label/deluge/plugins/

then reinstall

comment:2 Changed 6 years ago by Cas

  • Summary changed from deluge master git does not load plugins to 'git master' does not load plugins in Ubuntu

I put together a more complete solution but feel it needs some more work before committing to master:

https://github.com/cas--/Deluge/commits/Namespace_issue_plugins

comment:4 Changed 6 years ago by Cas

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 10 months ago by Cas

  • Milestone changed from 2.0.x to 2.x

Milestone renamed

Note: See TracTickets for help on using tickets.