Opened 13 years ago

Closed 13 years ago

#196 closed bug (Fixed)

Adding torrent problem, 'No such unique_ID.'

Reported by: tallica@… Owned by: andar
Priority: critical Milestone:
Component: Core Version: 0.5.9.0
Keywords: adding torrent Cc:

Description

Hello,

after adding new torrent to deluge I get:

Raising error: No such unique_ID. Unable to add torrent: 'No such unique_ID.' Raising error: No such unique_ID. Unable to save fastresume: 'No such unique_ID.' Raising error: No such unique_ID. Unable to scrape tracker 'No such unique_ID.'

and torrent doesn't show up in the gui list...

Here is what I get after restart Deluge:

Raising error: No such unique_ID. Unable to prioritize files: 'No such unique_ID.' Raising error: No such unique_ID. Traceback (most recent call last):

File "/usr/bin/deluge", line 133, in ?

start_deluge()

File "/usr/bin/deluge", line 116, in start_deluge

interface = deluge.interface.DelugeGTK()

File "/usr/lib64/python2.4/site-packages/deluge/interface.py", line 108, in init

self.apply_prefs()

File "/usr/lib64/python2.4/site-packages/deluge/interface.py", line 916, in apply_prefs

self.manager.apply_prefs()

File "/usr/lib64/python2.4/site-packages/deluge/core.py", line 1156, in apply_prefs

self.apply_prefs_per_torrent(unique_ID)

File "/usr/lib64/python2.4/site-packages/deluge/core.py", line 1160, in apply_prefs_per_torrent

self.get_pref("max_connections_per_torrent"))

File "/usr/lib64/python2.4/site-packages/deluge/core.py", line 1230, in set_max_connections_per_torrent

max_connections)

deluge.core.DelugeError?: 'No such unique_ID.'

I use Gentoo x86_64

Change History (12)

comment:1 Changed 13 years ago by tallica@…

Here is my emerge --info: http://tallica.pl/linux/emerge_info

comment:2 Changed 13 years ago by devangm@…

I get the same error, not while adding a torrent, but at start-up. I had 5 torrents queued/paused before upgrading.

I'm using Gentoo x86_64 too, with python 2.4.

comment:3 Changed 13 years ago by Devang <devangm@…>

Here is the start-up log, I can compile with the debug USE flag if needed...

no existing Deluge session Starting new Deluge session... deluge_core; using libtorrent 0.13.0.0. Compiled with NDEBUG. Applying preferences Raising error: No such unique_ID. Scanning plugin dir /usr/share/deluge/plugins Initialising plugin BlocklistImport? Initialising plugin DesiredRatio? Initialising plugin EventLogging? Initialising plugin FlexRSS Initialising plugin MoveTorrent? Initialising plugin NetworkGraph? Initialising plugin NetworkHealth? Initialising plugin Scheduler Initialising plugin Search Initialising plugin SpeedLimiter? Initialising plugin TorrentCreator? Initialising plugin TorrentFiles? Initialising plugin TorrentNotification? Initialising plugin TorrentPeers? Initialising plugin WebSeed? Initialising plugin WebUi? Applying preferences Starting DHT... Raising error: No such unique_ID. Unable to prioritize files: 'No such unique_ID.' Raising error: No such unique_ID. Traceback (most recent call last):

File "/usr/bin/deluge", line 133, in ?

start_deluge()

File "/usr/bin/deluge", line 116, in start_deluge

interface = deluge.interface.DelugeGTK()

File "/usr/lib64/python2.4/site-packages/deluge/interface.py", line 108, in init

self.apply_prefs()

File "/usr/lib64/python2.4/site-packages/deluge/interface.py", line 916, in apply_prefs

self.manager.apply_prefs()

File "/usr/lib64/python2.4/site-packages/deluge/core.py", line 1156, in apply_prefs

self.apply_prefs_per_torrent(unique_ID)

File "/usr/lib64/python2.4/site-packages/deluge/core.py", line 1160, in apply_prefs_per_torrent

self.get_pref("max_connections_per_torrent"))

File "/usr/lib64/python2.4/site-packages/deluge/core.py", line 1230, in set_max_connections_per_torrent

max_connections)

deluge.core.DelugeError?: 'No such unique_ID.'

comment:4 Changed 13 years ago by markybob

  • Resolution set to invalid
  • Status changed from new to closed

comment:5 Changed 13 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

I don't think the problem is corrupt configuration. I removed ~/.config/deluge, started deluge (0.5.9.0) again and added a torrent. Console output:

no existing Deluge session
Starting new Deluge session...
deluge_core; using libtorrent 0.13.0.0. Compiled with NDEBUG.
Applying preferences
Scanning plugin dir /usr/share/deluge/plugins
Initialising plugin SpeedLimiter
Initialising plugin FlexRSS
Initialising plugin TorrentNotification
Initialising plugin DesiredRatio
Initialising plugin WebUi
Initialising plugin MoveTorrent
Initialising plugin BlocklistImport
Initialising plugin EventLogging
Initialising plugin TorrentPeers
Initialising plugin Scheduler
Initialising plugin TorrentCreator
Initialising plugin TorrentFiles
Initialising plugin WebSeed
Initialising plugin NetworkHealth
Initialising plugin NetworkGraph
Initialising plugin Search
Applying preferences
Starting DHT...
No DHT file to resume
Showing window
Found TorrentFiles plugin...
Found TorrentPeers plugin...
Raising error: No such unique_ID.
Unable to add torrent: 'No such unique_ID.'
no old fastresume to delete
Raising error: No such unique_ID.
Unable to save fastresume:  'No such unique_ID.'

comment:6 Changed 13 years ago by Devang <devangm@…>

The same .config/deluge/persistent.state worked for me with 0.5.8.9 after downgrading.

I've gotten a couple errors like this before and I've always been able to mask the newer version and go back to the old one without doing anything to the .config/deluge directory. It's pretty unlikely that the config file is getting corrupted on it's own, and I haven't touched it since 5.5, but I can see I haven't been too helpful here.

Since there is no debug use flag, not sure what else I could do.

comment:7 Changed 13 years ago by tallica@…

I get same errors with old config as with new...

comment:8 follow-up: Changed 13 years ago by andar

Are you doing something silly like setting your autoadd folder the same as your torrentfiles location?

comment:9 in reply to: ↑ 8 Changed 13 years ago by anonymous

Replying to andar:

Are you doing something silly like setting your autoadd folder the same as your torrentfiles location?

no

comment:10 Changed 13 years ago by tallica@…

I've just tested Deluge 0.5.9.0 on 32bit Gentoo installation and it worked OK.

comment:11 Changed 13 years ago by tallica@…

I've also tested latest svn version on my x86_64 box, and there is no such problem...

x86_64 Gentoo: 0.5.8.9 - works OK 0.5.9.0 - doesn't work svn version - works OK

It seems that it's problem related to 0.5.9.0

comment:12 Changed 13 years ago by andar

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.