Opened 9 years ago

Closed 8 years ago

#1983 closed bug (Invalid)

Autoadd plugin not loading torrents with non-ascii char names

Reported by: thepace Owned by: Cas
Priority: minor Milestone: Future
Component: Plugin Version: 1.3.3
Keywords: autoadd, utf, non ascii Cc: non7top@…

Description

I load torrent by dropping them into watch folder and autoadd plugin loads them into deluge. On torrents with non-ascii character names files are not loaded into deluge and they stay in watch folder until i manually delete them. On manuall add via gui same torrent load properley.

sample file name that was not loaded:Los cronocrímenes

following error is written in deluged log:

[ERROR ] 00:56:46 core:204 Unable to auto add torrent due to inproper filename encoding: 'ascii' codec can't decode byte 0xc3 in position 19: ordinal not in range(128

OS used: ubuntu x64

Change History (6)

comment:1 Changed 9 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.4

comment:2 Changed 9 years ago by non7top

  • Cc non7top@… added

Same issue here with latest git

comment:3 Changed 9 years ago by Cas

  • Owner set to Cas
  • Status changed from new to accepted

comment:4 Changed 9 years ago by Cas

I am unable replicate this unless I set LC_ALL=C, can you check that you have UTF8 language set for the OS?

comment:5 Changed 9 years ago by thepace

  • Milestone changed from 1.3.4 to Future
  • Priority changed from major to minor

i pmd my seedbox provider to check this , but you are probably right since on other box i took later it worked fine. other one is dedi box so probably it does have utf on by default. thx for pointing out possible cause of this. i will probably close ticket once cause is confirmed

comment:6 Changed 8 years ago by Cas

  • Resolution set to invalid
  • Status changed from accepted to closed

The following code helped a user with the same issue determine that deluged was actually running with ANSI_X3.4-1968 (ASCII) instead of UTF8 so adding it here for reference.

diff --git a/deluge/main.py b/deluge/main.py
index b370c65..88268f8 100644
--- a/deluge/main.py
+++ b/deluge/main.py
@@ -209,7 +209,7 @@ def write_pidfile():
         pass
     deluge.log.setupLogger(level=options.loglevel, filename=options.logfile)
     from deluge.log import LOG as log
-
+    log.error(sys.getfilesystemencoding())
     if options.profile:
         import hotshot
         hsp = hotshot.Profile(deluge.configmanager.get_config_dir("deluged.profile"))
Note: See TracTickets for help on using tickets.