Opened 9 years ago

Closed 9 years ago

#2017 closed bug (WorksForMe)

WebUI gets into an endless Login loop

Reported by: Cas Owned by: damoxc
Priority: minor Milestone: 1.3.4
Component: Web UI Version: other (please specify)
Keywords: Cc:

Description

Forwarded from forum (needs verified): http://forum.deluge-torrent.org/viewtopic.php?f=7&t=38327

WebUI and password problems seem to have been discussed a lot here, but still this problem is quite maddening - here is the step-by-step:

(1) Start deluge (I use the deluge-gtk, from the desktop, for the moment)
(2) Connect to it using a browser - login using the default password
(3) Observe it all functioning properly - you can see the torrents, make changes, etc.
(4) Click the the Options/Prefs/Configure button and open the pane that lets you change
 the Password and/or the Timeout and other things
(5) Make ANY change there - e.g. set the timeout to something else.
(6) Hit Apply and/or OK
*** You get into an endless loop of Login Prompts !!! You are asked for your password
 again and again!

If you enter the:
(a) Correct password - you just get another login prompt window
(b) Incorrect password - you get an "You entered an incorrect password!" message
 and back to the login prompt.

No, I have not and do not wish to change the password! All I want is the WebUI to let me in! It clearly makes a distinction between the right and wrong passwords, but _something_ seems to get into some endless loop of logins when that particular config pane is used.

Change History (1)

comment:1 Changed 9 years ago by Cas

  • Resolution set to worksforme
  • Status changed from new to closed

Tested and could not repeat, although damoxc pointed out that the endless login prompt is probably due to different time zones for browser and server with the cookie expiring immediately so is not a bug we can fix.

Need missing details such as browser and deluge version.

Note: See TracTickets for help on using tickets.