Opened 10 years ago

Closed 10 years ago

#2044 closed bug (Fixed)

[Execute] Cannot re-enable plugin

Reported by: Cas Owned by:
Priority: major Milestone: 1.3.4
Component: Plugin Version: 1.3.3
Keywords: Cc:

Description

Enabled, disable then attempt to enable again results in this error:

--------------------------------------------------------------------------------
[ERROR   ] 22:03:12 client:395 RPCError Message Received!
--------------------------------------------------------------------------------
RPCRequest: core.enable_plugin(Execute)
--------------------------------------------------------------------------------
  File "/home/ubuntu/deluge.git/deluge/core/rpcserver.py", line 298, in dispatch
    ret = self.factory.methods[method](*args, **kwargs)
  File "/home/ubuntu/deluge.git/deluge/core/core.py", line 511, in enable_plugin
    return None
  File "/home/ubuntu/deluge.git/deluge/core/pluginmanager.py", line 82, in enable_plugin
    super(PluginManager, self).enable_plugin(name)
  File "/home/ubuntu/deluge.git/deluge/pluginmanagerbase.py", line 151, in enable_plugin
    component.start([instance.plugin._component_name])
  File "/home/ubuntu/deluge.git/deluge/component.py", line 278, in start
    if self.components[name]._component_depend:

KeyError: CorePlugin.Execute
--------------------------------------------------------------------------------

The only clue to the issue is that removing all the exported RPC methods from core.py stopped the error occurring.

Change History (1)

comment:1 Changed 10 years ago by Cas

  • Resolution set to fixed
  • Status changed from new to closed

Fixed 1.3-stable: 54769fe

Note: See TracTickets for help on using tickets.