Opened 9 years ago

Closed 9 years ago

#2106 closed bug (Invalid)

IOCTL sign extension errors

Reported by: mheppner Owned by:
Priority: major Milestone: Future
Component: libtorrent Version: 1.3.5
Keywords: ioctl, python, freebsd Cc: heppner.mark@…

Description

After upgrading some outdated packaged on my system, stdout repeatedly shows the following error message when Deluge is ran as a daemon:

WARNING pid 24074 (python2.7): ioctl sign-extension ioctl ffffffff8004667e

In the span of a few minutes, this repeats ~200 times. The program is slow to respond to the GUI client (on a different machine). I installed everything from the ports tree. I tried restoring the original configurations for Deluge, Python, and libtorrent, and recompiling them, but the same error occurs. I'm not sure if this is a libtorrent error or something with the version of Deluge in the FreeBSD ports tree.

FreeBSD 9.0 x64, Python 2.7.3, Deluge 1.3.5, Libtorrent rasterbar 0.15.9

Change History (4)

comment:1 Changed 9 years ago by mheppner

  • Cc heppner.mark@… added
  • Component changed from other to libtorrent
  • Priority changed from minor to major

comment:2 Changed 9 years ago by mheppner

After installing Deluge in an empty jail, the problem still exists. It only happens when there are active torrent connections, so I'm assuming the problem is in libtorrent. I tried using version 16 instead of 15, but then it can't find libiconv.

It looks like this was a problem from 2010 as well. It may be a language-specific problem, but libtorrent is obviously calling ioctl somewhere.

comment:3 Changed 9 years ago by Cas

  • Status changed from new to pending

You need to report to libtorrent mailing list or issue tracker

comment:4 Changed 9 years ago by Cas

  • Resolution set to invalid
  • Status changed from pending to closed
Note: See TracTickets for help on using tickets.