Opened 10 years ago

Closed 9 years ago

Last modified 6 years ago

#2128 closed bug (WorksForMe)

Move Storage moves wrong torrents.

Reported by: brooksaar Owned by:
Priority: critical Milestone:
Component: Unknown Version: 1.3.5
Keywords: Cc: th-deluge@…, brooksaar@…

Description

Using Deluge GTK client 1.3.5 on Windows connected to Deluge Server 1.3.5 on Debian Linux, when moving a completed torrent using the "Move Storage" option Deluge will often copy (not move, the original files are untouched) the wrong torrent.

Screenshot is attached. I asked Deluge GTK Client to move a movie torrent to my Movies folder, instead it copied 3 totally unrelated torrents to the Movies folder.

Attachments (1)

oHQp3.png (12.5 KB) - added by brooksaar 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by brooksaar

comment:1 Changed 10 years ago by thulle

  • Cc th-deluge@… added

I can confirm that "move storage" leaves the original files. I'm using version 1.3.5-0ubuntu2~precise1

comment:2 Changed 10 years ago by Cas

  • Status changed from new to pending

I am not sure how that is possible unless another program is interfering with the folders.

Can you provide debug logs please as this should show the path attempting to be moved and any failures.

comment:3 Changed 10 years ago by brooksaar

  • Status changed from pending to new
[DEBUG   ] 19:33:24 torrentmanager:983 on_alert_tracker_error
[DEBUG   ] 19:33:28 core:390 Moving storage ('e37c3a6a94a31790ac665f7c5e3d108dac270491',) to /home/aaron/Videos/Movies
[DEBUG   ] 19:35:36 torrentmanager:687 Saving torrent state file.

Excerpt from the debug log (it's 2.3mb, and filled with passkeys so I don't really want to post it, let me know if you need it). I'm not sure if lines 1 and 3 are relevant to the move action. The hash e37c3a6a94a31790ac665f7c5e3d108dac270491 is the same as the torrent I attempted to move according to the Windows Deluge GTK UI (still 1.3.5).

In /home/aaron/Videos/Movies I now have 2 files duplicated from other torrents (a 500mb RAR and a 3.4gb ISO) both time stamped with a creation date of 19:33, ie. the same time I started the moving storage action. The torrent I attempted to move is still in it's original location (/home/aaron/Downloads/Torrents/Complete).

Thanks for taking the time to examine this!

comment:4 Changed 10 years ago by brooksaar

  • Cc brooksaar@… added
  • Status changed from new to pending

Didn't mean to change the status to new...

Also, the duplication of files does not stop until deluged is killed. Since my previous post 3 minutes ago 4 more files from other torrents have been duplicated into my /home/aaron/Videos/Movies folder. Sorry for double posting!

comment:5 Changed 9 years ago by Cas

  • Milestone changed from Future to 1.3.6

comment:6 Changed 9 years ago by gazpachoking

I can't seem to reproduce this. I'm testing with windows 7 64 client, and ubuntu 12.04 32 bit daemon. Deluge 1.3.5 on both, libtorrent 0.15.10. Is there any more info to reliably reproduce? What libtorrent version is running on the server? Do the moved torrents contain subdirectories?

comment:7 Changed 9 years ago by Cas

  • Milestone changed from 1.3.6 to 1.3.x

comment:8 Changed 9 years ago by Cas

  • Resolution set to worksforme
  • Status changed from pending to closed

comment:9 Changed 6 years ago by Cas

  • Milestone 1.3.x deleted

Milestone deleted

Note: See TracTickets for help on using tickets.