Opened 9 years ago

Closed 9 years ago

#2302 closed bug (Fixed)

deluge-gtk crashed with IndexError in get_plugin_info

Reported by: Cas Owned by:
Priority: trivial Milestone: 1.3.7
Component: Core Version: 1.3.6
Keywords: Cc:

Description

Forwarded from: https://bugs.launchpad.net/ubuntu/+source/deluge/+bug/733094

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/deluge/ui/gtkui/preferences.py", line 865, in on_plugin_selection_changed
    plugin_info = component.get("PluginManager").get_plugin_info(name)
  File "/usr/lib/pymodules/python2.7/deluge/pluginmanagerbase.py", line 169, in get_plugin_info
    for line in self.pkg_env[name][0].get_metadata("PKG-INFO").splitlines():
IndexError: list index out of range

I also encountered this in 1.3.6 and I think it was caused by deleting a plugin while deluge gtk was running. A trivial bug but should be looked into.

Change History (1)

comment:1 Changed 9 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.7
  • Resolution set to fixed
  • Status changed from new to closed

Fixed 1.3-stable: 27bfa5a64933a

Note: See TracTickets for help on using tickets.