Opened 10 years ago

Closed 10 years ago

#2384 closed bug (WorksForMe)

invisible throttling bug?

Reported by: demian Owned by:
Priority: major Milestone: Future
Component: Core Version: 1.3.6
Keywords: download speed throttled Cc:

Description

hey,

versions:

deluged 1.3.6 libtorrent-rasterbar 0.16.12 (same with 0.16.10)

My deluge is behaving rather odd and because it's not that easy to explain i will add two gifs at the end of the post.

So: I have 100Mbit downstream, meaning i should get up to ~11 MBps download speed. And with other torrent clients like Vuze or rtorrent i get that, if there are enough seeds, that is.

But with deluge i never get more than 2 MBps downstream, irregardless of how many torrents i have open. As if i had throttled the dl speed. Upstream is NOT affected.

So, i usually hang somewhere between 1.5 MBps and 2 MBps. On a single torrent I can get up to 4-5 MBps but it is very rare. I've actually only ever seen it on one torrent, which incidentally is also the only torrent, I can get the full 11 MBps, which i get by pausing and then unpausing... Yes, it sounds weird, there is a demo gif attached (gif 1). All other torrents I have tested so far cap at around 2 MBps and those are torrents which, if opened in rtorrent or vuze, download at least 3 times as fast, often at the cap of ~11 MBps.

I have tried the unpausing with different torrents but this archlinux one, is the only one that resumes with full speed (gif 1). And to add to the confusion, if i have other torrents open while doing the pause/resume voodoo, global download speed will still be capped at 2 MBps.

I have tried: current git version of deluge downgrading libtorrent-rasterbar (to 0.16.10) deleting all configuration files changing all kinds of options (DHT, Peer Exchange, TOS, Encryption, every bandwidth option to -1 etcpp)

To me it seems, the problem has to be within the deluge code unless i am somehow missing a crucial option.

Maybe someone here can make sense of this. Gifs: http://a.pomf.se/l84ay.gif http://a.pomf.se/v67dw.gif

A log of the first gif (full speed after resume): http://bpaste.net/show/156682/

Change History (7)

comment:1 Changed 10 years ago by avolation

A little over a week ago this same situation started with me. Regardless of the tracker or amount of seeders. I am capped at between 1.5MB/s and 2MB/s down. I'm on a 50mbps connection and regularly pulled 6.2MB/s down before recently. Pausing and resuming some torrents allows for full speed transfer, but only sometimes.

The same torrents transfer at full speed using transmission or rtorrent.

Client: 1.3.6

libtorrent: 0.16.11.0

Last edited 10 years ago by avolation (previous) (diff)

comment:2 follow-up: Changed 10 years ago by Ratanak

All of the traffic happens in libtorrent and since you have no limit set for global download speed, libtorrent is probably the source of the problem. Do you have this issue with other libtorrent (rasterbar, not rakshasa) based torrent clients?

Note: rTorrent uses the rakshasa library.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 10 years ago by avolation

Replying to Ratanak:

All of the traffic happens in libtorrent and since you have no limit set for global download speed, libtorrent is probably the source of the problem. Do you have this issue with other libtorrent (rasterbar, not rakshasa) based torrent clients?

Note: rTorrent uses the rakshasa library.

After about 2 weeks of experimenting (and forgetting about this post till you just replied). It seems that "Rate limit IP overhead" checkbox is getting 'checked' on every deluge restart, yet it isn't actually showing as checked in deluge.

While I have 50mbps my isp only gives me 2mbps up. I always keep my Maximum upload speed at 150KB/s rather than my 250KB/s maximum to avoid slowing other browsing activity down.

SO. After I would reboot and restart deluge, I would be limited to 150KB/s REGARDLESS if I was uploading or not. When in reality if I'm downloading from 30 peers at 5MB/s, deluge would be using a good 100KB/s of my upstream bandwidth just to keep up with that download (acks and so fourth.) If I was seeding something at 100KB/s (which I usually am.) It would slow my download down DRAMATICALLY because it couldn't keep up with the acks.

TL;DR. "Rate limit IP overhead" is acting as if it is checked every restart of deluge(daemon) for me. It just needs to be checked then unchecked again to work right atm. Hopefully if anyone else has this issue it will help them not pull their hair out.

comment:4 in reply to: ↑ 3 ; follow-up: Changed 10 years ago by Ratanak

Replying to avolation:

Replying to Ratanak:

All of the traffic happens in libtorrent and since you have no limit set for global download speed, libtorrent is probably the source of the problem. Do you have this issue with other libtorrent (rasterbar, not rakshasa) based torrent clients?

Note: rTorrent uses the rakshasa library.

...

TL;DR. "Rate limit IP overhead" is acting as if it is checked every restart of deluge(daemon) for me. It just needs to be checked then unchecked again to work right atm. Hopefully if anyone else has this issue it will help them not pull their hair out.

I see. It doesn't seem to be the same issue as OP though. OP should be getting ~11 MiB/s but is only getting ~2 MiB/s.

Version 0, edited 10 years ago by Ratanak (next)

comment:5 in reply to: ↑ 4 Changed 10 years ago by avolation

I see. It doesn't seem to be the same issue as OP though. OP should be getting ~11 MiB/s but is only getting ~2 MiB/s.

Well, You would think that(as would anyone else.) But regardless of how much I was uploading at the time. When it started throttling because of the rate limit switch. It was ALWAYS straight down to 1.5-2MB/s down. It would not just use EXACTLY how much upstream bandwidth I had left in my 'Maximum upload speed' setting and make my download speed match it. It acted as if it was actually limiting my downloads to 2MB/s (generally 80-110KB/s upstream is needed for this if its many peers, but I tested this on a few private trackers with as little as 2-5 peers) AND then give whatever was left to seeding torrents. Basically the second I started seeding .1KB/s my down speed would instantly drop to 2MB/s. It's so strange that the little setting would even come close to doing something like that. But it is indeed the cause(For my problem.)

While not even close to being definitive, I believe its strange enough and close enough to the original bug submitter's numbers to possibly be related.

comment:6 Changed 10 years ago by demian

Hey,

after submitting the ticket i resorted to using rtorrent for a couple of weeks. Yesterday I switched back to deluge to try out avolations suggestion but I didn't have to since the throttling was no longer present. I am not sure what happened since both deluge and libtorrent-rasterbar have not changed versions in these past 3 weeks. There is one change i made which is buy a new router. I went from an old D-Link 524 to a TP-Link WDR3600. But as stated in my OP, deluge was the only client that had this speed-throttling issue so I would be surprised if the issue was in fact hardware related. As I'm using ArchLinux? i have went through quite a few system upgrades in 3 weeks so it still might be some other software that was changed to resolve this issue. I did not knowingly change any TCP/UDP related configurations that could explain this, neither did I change anything in the deluge configuration. I just started from the last known state of 3 weeks ago, added some torrents and immediately got full speed on most. Since there also seem to be few people, if any, that experienced this issue, there is probably no reason to keep this ticket open.

Regards, demian

comment:7 Changed 10 years ago by Cas

  • Resolution set to WorksForMe
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.