Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#2448 closed bug (Fixed)

Resume data is saved individually for all torrents on startup

Reported by: m!nus Owned by:
Priority: major Milestone: 2.x
Component: Core Version: develop
Keywords: startup, resume data, alerts Cc:

Description

On startup, after all torrents have been loaded, Deluge will start re-saving resume data, for each torrent individually. With 800 torrents this makes Deluge unresponsive for 2 minutes for me.

This is caused by all torrents getting paused and unpaused, or at least the respective alerts being emitted. Deluge saves resume data in on_alert_torrent_paused.

The proper way to fix this should be to prevent those alerts.

Change History (3)

comment:1 Changed 8 years ago by m!nus

This seems to be fixed in dev307 (libtorrent: 0.16.17.0)

comment:2 Changed 8 years ago by Cas

  • Resolution set to Fixed
  • Status changed from new to closed

comment:3 Changed 5 years ago by Cas

  • Milestone changed from 2.0.x to 2.x

Milestone renamed

Note: See TracTickets for help on using tickets.