Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2460 closed bug (Invalid)

AutoExtractor Plugin fails to extract files with periods

Reported by: djstrobel Owned by:
Priority: minor Milestone: 1.3.7
Component: Plugin Version: 1.3.6
Keywords: Cc:

Description

I found ticket #2290 and made sure I have the Extractor-0.3-py2.7.egg installed. Still getting this same error:

Line 1619: [ERROR ] 18:22:02 core:139 EXTRACTOR: Can't extract unknown file type: .x264-2hd.rar

Attachments (1)

deluged.log (163.2 KB) - added by djstrobel 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by djstrobel

comment:1 Changed 10 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.7

comment:2 Changed 10 years ago by Cas

  • Resolution set to Invalid
  • Status changed from new to closed

Ok you are not actually running the latest plugin as the logging line is from old code. There can be a problem with using an egg to replace packaged plugins, you will need to find the previously installed Extractor plugin and delete it.

comment:3 Changed 10 years ago by djstrobel

Thanks for looking at it Cas,

I'm not sure how else to get the new plugin working. I already deleted the built-in 0.2 under /usr/share/pyshared/deluge/plugins before submitting this ticket. The log file even says it found 0.3 under /home/deluge/.config/deluge/plugins/Extractor-0.3-py2.7.egg.

What am I missing, can you help please?

comment:4 Changed 10 years ago by djstrobel

In case anyone else runs into this problem, I finally fixed it by replacing /usr/lib/python2.7/dist-packages/deluge/plugins/Extractor-0.2.egg with Extractor-0.3.egg. I had already found and replaced it under /usr/share/pyshared/deluge/plugins/ but didn't know it was in a second spot as well.

Note: See TracTickets for help on using tickets.