Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#2469 closed bug (Fixed)

[Win32] Pyopenssl 0.14 missing module

Reported by: Doadin Owned by: Cas
Priority: minor Milestone: 2.x
Component: Packaging Version: develop
Keywords: Cc:

Description

I dont see this one in the build instructions or anything and it runs without it but it could cuase omse issues maybe? When opening deluged-debug from the development branch it outputs:

: UserWarning?: You do not have a working installation of the service_identity module: 'No module named service_identity'. Please install it from <https://pypi.python.org/pypi/service_identity> and make sure all of its dependencies are satisfied. Without the service_identity module and a recent enough pyOpenSSL to support it, Twisted can perform only rudimentary TLS client hostname verification . Many valid certificate/hostname mappings may be rejected.

Would might want to also look into adding support for the new pyopenssl.

Change History (10)

comment:1 Changed 10 years ago by Doadin

  • Milestone changed from Future to 1.4.0
  • Version changed from other (please specify) to develop (git)

comment:2 Changed 10 years ago by Cas

  • Component changed from other/unknown to Packaging
  • Owner set to Cas
  • Status changed from new to assigned

This must be a new requirement for Windows.

I am not sure what you mean add support for new pyopenssl, there is nothing we can do.

comment:3 Changed 10 years ago by Doadin

From my attempts at building with the new pyopenssl(0.14) i was under the impression that it only didnt work because of missing dependencies(new) and a reference to a sub module? sorry new to python/gtk that is either moved or no longer exists. And therefore all that would need to change is updateing w.e. code refers to the old module and adding the new dependencies to the build. Unless the missing sub module provided something no longer possible in new versions? I say only but im not sure how deep the use of pyopenssl goes, which parts even use it.(there is alot of source to go through)

comment:4 Changed 10 years ago by Cas

  • Summary changed from Missing Module to [Win32] Pyopenssl 0.14 missing module

I looked into this and found that you will need to install cryptography before install pyopenssl 0.14.

pip install cryptography
pip install pyopenssl --upgrade

After doing this I am not seeing any warnings so if you also see no issues, the docs can be updated and this ticket can be closed.

comment:5 Changed 10 years ago by Doadin

As i had noted here:http://forum.deluge-torrent.org/viewtopic.php?f=8&t=47537#p197753 there was an issue with using pyopenssl 0.14 in general and now that doesnt seem to be the case following your directions however the message in the description of this ticket still happens.

comment:6 Changed 10 years ago by Cas

Ok, strange I am not seeing that message.

Can you verify that this resolves the issue:

pip install service_identity

comment:7 Changed 10 years ago by Doadin

I ran the install on a different computer than i have been using(not sure if this one had the message or not) but i doesnt appear now after "pip install service_identity".

Version 0, edited 10 years ago by Doadin (next)

comment:8 Changed 10 years ago by Cas

  • Resolution set to Fixed
  • Status changed from assigned to closed

comment:10 Changed 7 years ago by Cas

  • Milestone changed from 2.0.x to 2.x

Milestone renamed

Note: See TracTickets for help on using tickets.