Opened 8 years ago

Closed 8 years ago

#2487 closed bug (Fixed)

Deluge 1.3.7 windows can't connect to SSL tracker

Reported by: Ethorsen Owned by:
Priority: major Milestone: 1.3.8
Component: Packaging Version: 1.3.7
Keywords: SSL https announce Cc:

Description

My users started complaining that the SSL torrent were no longer working after upgrading from 1.3.6 to 1.3.7

I added some logging server side to see what was happening, but the requests are not going through.

I then tested another tracker I have to see if it was my certificate or server causing the problem, but it was the same for it. Everything is fine in 1.3.6

On Windows 7, from the installer. Simply add a torrent that has a SSL tracker to reproduce.

Attachments (1)

ssl_debug.txt (2.7 KB) - added by Ethorsen 8 years ago.
Debug file

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Ethorsen

Debug file

comment:1 Changed 8 years ago by Cas

  • Component changed from other/unknown to Packaging
  • Version changed from other (please specify) to 1.3.7

There is a pinned post in the windows forum... http://forum.deluge-torrent.org/viewtopic.php?f=12&t=48005

I will sort this soon as it appears the new libtorrent build is working for users.

comment:2 Changed 8 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.8

comment:3 Changed 8 years ago by Cas

Note to self: must manually package latest openssl dlls, and not rely on pyopenssl ones.

comment:4 Changed 8 years ago by Cas

  • Resolution set to Fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.