Opened 6 years ago

Closed 6 years ago

#2721 closed bug (Fixed)

Limited functionality on rutracker.org

Reported by: xtemp09 Owned by:
Priority: minor Milestone: 1.3.12
Component: Core Version: 1.3.11
Keywords: pass key exposure Cc:

Description

Could you turn off passkey exposure by default? This option turned off will let rutracker.org's administration unban Deluge and finally stop this useless fight.

Change History (3)

comment:1 Changed 6 years ago by Cas

  • Component changed from Core to libtorrent
  • Resolution set to Invalid
  • Status changed from new to closed

comment:2 Changed 6 years ago by xtemp09

  • Component changed from libtorrent to Core
  • Resolution Invalid deleted
  • Status changed from closed to reopened

comment:3 Changed 6 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.12
  • Resolution set to Fixed
  • Status changed from reopened to closed

It is not a bug. It is an issue with private trackers being added to a public torrent while the libtorrent shared trackers plugin is enabled. Please read: #2359

I have made a concession though and added code [2b08ed06af7c6] so that libtorrent version greater that 0.16.7 will no longer have the lt_trackers extension enabled by default on Deluge 1.3. The problem is that Deluge 1.3 can use libtorrent versions less that 0.16.7 (e.g. 0.15.10 is common) but the private trackers have no way of knowing which version of libtorrent is in use with 1.3 and may remain banned.

The next major version of Deluge will have control of the extension: #2254

Note: See TracTickets for help on using tickets.