Opened 6 years ago

Closed 6 years ago

#2757 closed bug (Fixed)

Error creating torrent with french translation

Reported by: Cas Owned by: Cas
Priority: major Milestone: 1.3.12
Component: Translations Version: 1.3.11
Keywords: Cc:

Description

From forum post:

    Traceback (most recent call last):
      File "deluge\ui\gtkui\createtorrentdialog.py", line 166, in _on_button_file_clicked
      File "deluge\ui\gtkui\createtorrentdialog.py", line 134, in adjust_piece_size
      File "deluge\ui\gtkui\createtorrentdialog.py", line 119, in parse_piece_size_text
    ValueError: invalid literal for int() with base 10: '32\xc2'

    Traceback (most recent call last):
      File "deluge\ui\gtkui\createtorrentdialog.py", line 307, in _on_button_save_clicked
      File "deluge\ui\gtkui\createtorrentdialog.py", line 119, in parse_piece_size_text
    ValueError: invalid literal for int() with base 10: '16\xc2'

The problem is that fr.po contains non-breaking spaces (\xc2) so the solution is to parse it and remove/replace them on the Launchpad translation site.

Change History (1)

comment:1 Changed 6 years ago by Cas

  • Resolution set to Fixed
  • Status changed from new to closed

Fix applied to Launchpad

Note: See TracTickets for help on using tickets.