Opened 2 years ago

Closed 2 years ago

#2795 closed bug (Fixed)

Add Torrent window too high for netbook displays (1024x600) on Gnome 3.14

Reported by: johnchristopher Owned by: Cas
Priority: minor Milestone: 1.3.13
Component: GTK UI Version: 1.3.10
Keywords: Cc:

Description

The Add Torrent window does not fit vertically on a 1024x600 screen in GNOME 3.14 with default gnome configuration (one bar on top). The buttons on the bottom edge are off screen. This happens always, no matter if you add one or more torrents. Hitting the enter key doesn't work either (though tabbing through the controls might work, I haven't tried).

Seems to be a regression from http://dev.deluge-torrent.org/ticket/518.

edit: deluge 1.3.10 (default Debian 8 package)

Attachments (2)

scrs1.png (45.5 KB) - added by bro 2 years ago.
scrs2.png (81.3 KB) - added by bro 2 years ago.

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by bro

Changed 2 years ago by bro

comment:1 Changed 2 years ago by Cas

  • Milestone changed from needs verified to 1.3.13

comment:2 Changed 2 years ago by Cas

The problem is compounded by the theme having a larger dialog header and buttons...

The current dialog (on Ubuntu) is ~574px high so if we aim to keep the default dialog height to under 500px, that should accommodate desktop elements and themes.

There are key shortcuts for those buttons, Add: Alt-A, Cancel: Alt-C

Last edited 2 years ago by Cas (previous) (diff)

comment:3 Changed 2 years ago by Cas

  • Resolution set to Fixed
  • Status changed from new to closed

Fixed in 1.3-stable: [6240243251e99]

comment:4 Changed 2 years ago by Cas

  • Milestone changed from 1.3.13 to 2.0
  • Resolution Fixed deleted
  • Status changed from closed to reopened

Forgot will need to do the same on develop branch...

comment:5 Changed 2 years ago by Cas

  • Owner set to Cas
  • Status changed from reopened to assigned

comment:6 Changed 2 years ago by Cas

  • Milestone changed from 2.0 to 1.3.13
  • Resolution set to Fixed
  • Status changed from assigned to closed

Fixed in develop: [c2d7f3c6530c79]

Note: See TracTickets for help on using tickets.