Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#2804 closed bug (Fixed)

unable to add torrents

Reported by: firefox Owned by: bro
Priority: minor Milestone: 2.0.0
Component: Core Version: develop
Keywords: Cc:

Description (last modified by Cas)

$ deluge

23:08:11.145 [ERROR   ][deluge.pluginmanagerbase               :144 ] Component already registered with name GtkPlugin.AutoAdd
23:08:11.145 [ERROR   ][deluge.pluginmanagerbase               :144 ] Component already registered with name GtkPlugin.Stats
23:08:11.145 [ERROR   ][deluge.pluginmanagerbase               :144 ] Component already registered with name GtkPlugin.WebUi
23:08:11.146 [ERROR   ][deluge.pluginmanagerbase               :144 ] Component already registered with name GtkPlugin.Blocklist
23:08:11.146 [ERROR   ][deluge.pluginmanagerbase               :144 ] Component already registered with name GtkPlugin.Label
Unhandled Error
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/deluge-2.0.0.dev603-py2.7.egg/deluge/core/daemon_entry.py", line 121, in run_daemon
    daemon.start()
  File "/usr/local/lib/python2.7/dist-packages/deluge-2.0.0.dev603-py2.7.egg/deluge/core/daemon.py", line 144, in start
    reactor.run()
  File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1194, in run
    self.mainLoop()
  File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1203, in mainLoop
    self.runUntilCurrent()
--- <exception caught here> ---
  File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 825, in runUntilCurrent
    call.func(*call.args, **call.kw)
  File "/usr/local/lib/python2.7/dist-packages/deluge-2.0.0.dev603-py2.7.egg/deluge/core/torrentmanager.py", line 408, in on_add_torrent_alert
    d, options, state, filename, magnet, resume_data, filedump, save_state = self.torrents_loading.pop(torrent_id)
exceptions.KeyError: 'd65db24766e6cf2244a7d35af524ecff66617b75'

23:09:09.626 [CRITICAL][twisted                         :154 ] Unhandled Error
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/deluge-2.0.0.dev603-py2.7.egg/deluge/core/daemon_entry.py", line 121, in run_daemon
    daemon.start()
  File "/usr/local/lib/python2.7/dist-packages/deluge-2.0.0.dev603-py2.7.egg/deluge/core/daemon.py", line 144, in start
    reactor.run()
  File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1194, in run
    self.mainLoop()
  File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 1203, in mainLoop
    self.runUntilCurrent()
--- <exception caught here> ---
  File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 825, in runUntilCurrent
    call.func(*call.args, **call.kw)
  File "/usr/local/lib/python2.7/dist-packages/deluge-2.0.0.dev603-py2.7.egg/deluge/core/torrentmanager.py", line 408, in on_add_torrent_alert
    d, options, state, filename, magnet, resume_data, filedump, save_state = self.torrents_loading.pop(torrent_id)
exceptions.KeyError: 'd65db24766e6cf2244a7d35af524ecff66617b75'

23:09:38.234 [ERROR   ][deluge.ui.client                       :157 ] RPCError Message Received!
--------------------------------------------------------------------------------
RPCRequest: core.add_torrent_magnet(magnet:?xt=urn:btih:D65DB24766E6CF2244A7D35AF524ECFF66617B75&amp;tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&amp;tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&amp;tr=udp%3A%2F%2Ftracker.ccc.de%3A80, {'add_paused': False, 'max_download_speed': -1.0, 'move_completed_path': '/media/truecrypt1/download/completi/vari', 'download_location': '/media/truecrypt1/download/Incomplete', 'seed_mode': False, 'max_upload_speed': -1.0, 'prioritize_first_last_pieces': False, 'max_upload_slots': -1, 'move_completed': True, 'pre_allocate_storage': False, 'sequential_download': False, 'max_connections': -1})
--------------------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/deluge-2.0.0.dev603-py2.7.egg/deluge/core/rpcserver.py", line 293, in dispatch
    ret = self.factory.methods[method](*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/deluge-2.0.0.dev603-py2.7.egg/deluge/core/core.py", line 319, in add_torrent_magnet
    return self.torrentmanager.add(magnet=uri, options=options)
  File "/usr/local/lib/python2.7/dist-packages/deluge-2.0.0.dev603-py2.7.egg/deluge/core/torrentmanager.py", line 340, in add
    raise AddTorrentError("Torrent already being added (%s)." % torrent_id)
AddTorrentError: Torrent already being added (D65DB24766E6CF2244A7D35AF524ECFF66617B75).

AddTorrentError: Torrent already being added (D65DB24766E6CF2244A7D35AF524ECFF66617B75).
--------------------------------------------------------------------------------
Unhandled error in Deferred:
23:09:38.235 [CRITICAL][twisted                                :154 ] Unhandled error in Deferred:


Traceback (most recent call last):
Failure: deluge.error.AddTorrentError: Torrent already being added (D65DB24766E6CF2244A7D35AF524ECFF66617B75).
23:09:38.235 [CRITICAL][twisted                                :154 ] 
/usr/local/lib/python2.7/dist-packages/deluge-2.0.0.dev603-py2.7.egg/deluge/ui/gtkui/listview.py:432: GtkWarning: IA__gtk_tree_view_remove_column: assertion 'column->tree_view == GTK_WIDGET (tree_view)' failed
  self.treeview.remove_column(self.columns[header].column)

Change History (4)

comment:1 Changed 5 years ago by Cas

  • Description modified (diff)

comment:2 Changed 5 years ago by bro

  • Component changed from other/unknown to Core
  • Milestone changed from needs verified to 2.0
  • Owner set to bro
  • Priority changed from blocker to minor
  • Status changed from new to assigned

The problem is limited to magnet links with uppercase hash.

comment:3 Changed 5 years ago by Cas

  • Resolution set to Fixed
  • Status changed from assigned to closed

Fixed in develop: [5c69b56c]

comment:4 Changed 3 years ago by Cas

  • Milestone changed from 2.0 to 2.0.0

Milestone renamed

Note: See TracTickets for help on using tickets.