Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#2808 closed bug (Fixed)

Deluge Log File Not Working as Intended

Reported by: Doadin Owned by:
Priority: minor Milestone: 2.0.0
Component: Core Version: develop
Keywords: Cc:

Description

On a python 2.7 build writeing logs to a file doesnt work properly. if you set rotatiing logs it works fine however normal loging (filemode w?) the log is cleared every time it writes a new line. So instead of having a clear fresh log every time you open deluge what you have it just one line staying something about shuting down (or w.e. the last message is). What seems to be happening is it opens the file clears it writes the message closes then repeats every message.

Change History (8)

comment:1 Changed 8 years ago by bro

On what OS are you testing this?

comment:2 Changed 8 years ago by bro

  • Milestone changed from 1.3.13 to 2.0

comment:3 Changed 8 years ago by bro

Can you test if this fixes the issue: https://github.com/bendikro/deluge/commit/58bc8b6ec79b4e9d120e6356fb142cbea61682e0

This may work if the problem is due to using WatchedFileHandler? on Windows.

comment:4 Changed 8 years ago by Doadin

Currently on windows 10 it also happened on windows 8/8.1 if i remeber correctly. And yes i can test.

comment:5 Changed 8 years ago by Doadin

Last edited 8 years ago by Doadin (previous) (diff)

comment:6 Changed 8 years ago by Doadin

Appears to fix it! tested win 7 and win 10.

Last edited 8 years ago by Doadin (previous) (diff)

comment:7 Changed 8 years ago by Cas

  • Resolution set to Fixed
  • Status changed from new to closed

Merged in develop: [58bc8b6ec7]

comment:8 Changed 5 years ago by Cas

  • Milestone changed from 2.0 to 2.0.0

Milestone renamed

Note: See TracTickets for help on using tickets.