Opened 2 years ago

Closed 2 years ago

#2811 closed bug (Invalid)

create_plugin.py creates plugin with bug

Reported by: haydent Owned by:
Priority: major Milestone: needs verified
Component: Plugin Version: 1.3.12
Keywords: Cc:

Description

per this investigation here: http://forum.deluge-torrent.org/viewtopic.php?f=7&t=53942&p=223969#p223969

If i follow the guide here: http://dev.deluge-torrent.org/wiki/Development/1.3/Plugin and create the plugin template, the compiled plugin runs fine on first activation but on program relaunch deluge fails with this error log attached.

Im running classic mode under windows 7, i have tried compiling under linux or windows with same result.

I can get it to not make the error by setting up setup.py and plugin dir structure the way another plugin i found does, as it does not have this problem.

I have attached screenshot of difference between setup.py with working one on right and problem one on left. The code for these can be found at the forum post above.

Attachments (2)

Capture.JPG (130.4 KB) - added by haydent 2 years ago.
screenshot
error_log.txt (2.8 KB) - added by haydent 2 years ago.
deluged.exe error log

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by haydent

screenshot

Changed 2 years ago by haydent

deluged.exe error log

comment:1 Changed 2 years ago by Cas

It looks like you are trying to use develop plugins with 1.3? So you did not follow the wiki link to the correct script.

Last edited 2 years ago by Cas (previous) (diff)

comment:2 Changed 2 years ago by Cas

  • Resolution set to Invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.