Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#2813 closed bug (Fixed)

Connection Manager Showing Daemon Offline On First Start

Reported by: Doadin Owned by:
Priority: major Milestone: 2.0.0
Component: GTK UI Version: develop
Keywords: Cc:

Description (last modified by Cas)

Start deluged then gtkui and opening the connection manager will say the daemon is offline but if you hit connect then manually close the connection manager it connects fine.

And from there on if you disconnect from daemon or restart it or w.e. as long as you don't restart the gtkui it will see it online but if you close the ui you can still connect like before but it wont say online and you have to manually close the connection manager after hitting connect.(just like the first time)

Change History (7)

comment:1 Changed 5 years ago by Cas

  • Description modified (diff)
  • Milestone changed from 2.0.x to 2.0

comment:2 Changed 5 years ago by Doadin

A little more info in logs it says

12:22:09.069 [DEBUG   ][deluge.ui.client            :259 ] sslproxy.connect()
12:22:09.069 [INFO    ][twisted                     :154 ] Starting factory <deluge.ui.client.DelugeRPCClientFactory instance at 0x0535A4B8>
12:22:09.085 [INFO    ][deluge.ui.client            :197 ] Connecting to daemon at "127.0.0.1:58846"...
12:22:09.085 [DEBUG   ][deluge.ui.gtkui.connectionmanager:399 ] Status: Offline
12:22:22.882 [DEBUG   ][deluge.ui.client            :259 ] sslproxy.connect()
12:22:22.882 [INFO    ][twisted                     :154 ] Starting factory <deluge.ui.client.DelugeRPCClientFactory instance at 0x0535A940>
12:22:22.882 [INFO    ][deluge.ui.client            :197 ] Connecting to daemon at "127.0.0.1:58846"...
12:23:42.163 [DEBUG   ][deluge.config               :194 ] Setting 'hosts' to [] of <type 'list'>
12:23:42.163 [DEBUG   ][deluge.config               :458 ] Saving new config file C:\Users\doadin\AppData\Roaming\deluge\hostlist.conf.1.2.new
12:23:42.194 [DEBUG   ][deluge.config               :471 ] Backing up old config file to C:\Users\doadin\AppData\Roaming\deluge\hostlist.conf.1.2.bak
12:23:42.194 [DEBUG   ][deluge.config               :479 ] Moving new config file C:\Users\doadin\AppData\Roaming\deluge\hostlist.conf.1.2.new to C:\Users\doadin\AppData\Roaming\deluge\hostlist.conf.1.2..
12:23:42.194 [WARNING ][deluge.ui.client            :201 ] Connection to daemon at "127.0.0.1:58846" failed: User timeout caused connection failure.
12:23:42.194 [DEBUG   ][deluge.ui.client            :556 ] on_connect_fail: [Failure instance: Traceback (failure with no frames): <class 'twisted.internet.error.TimeoutError'>: User timeout caused connection failure.
]
12:23:42.194 [DEBUG   ][deluge.ui.client            :275 ] sslproxy.disconnect()
12:23:42.194 [INFO    ][twisted                     :154 ] Stopping factory <deluge.ui.client.DelugeRPCClientFactory instance at 0x0535A4B8>
12:23:42.194 [WARNING ][deluge.ui.client            :201 ] Connection to daemon at "127.0.0.1:58846" failed: User timeout caused connection failure.
12:23:42.194 [DEBUG   ][deluge.ui.client            :556 ] on_connect_fail: [Failure instance: Traceback (failure with no frames): <class 'twisted.internet.error.TimeoutError'>: User timeout caused connection failure.

However if you just close then reopen connection manager it says:

12:23:43.569 [DEBUG   ][deluge.ui.client            :259 ] sslproxy.connect()
12:23:43.569 [INFO    ][twisted                     :154 ] Starting factory <deluge.ui.client.DelugeRPCClientFactory instance at 0x05352E40>
12:23:43.569 [INFO    ][deluge.ui.client            :197 ] Connecting to daemon at "127.0.0.1:58846"...
12:23:43.569 [DEBUG   ][deluge.ui.gtkui.connectionmanager:399 ] Status: Offline
12:23:43.569 [INFO    ][deluge.ui.client            :85  ] Connected to daemon at 127.0.0.1:58846..
12:23:43.569 [DEBUG   ][deluge.ui.client            :362 ] __on_connect called
12:23:43.663 [DEBUG   ][deluge.ui.client            :366 ] Got info from daemon: 2.0.0.dev641
12:23:43.663 [DEBUG   ][deluge.ui.client            :552 ] on_connected. Daemon version: 2.0.0.dev641

comment:3 Changed 5 years ago by Doadin

Sorry for the spam a little here but ive also noticed that no matter what order you start the ui or daemon in or if you have the connection manager open, if you set the conncection manager to not open at startup then manually open it at any time before or after starting the daemon doesnt matter itll work as intended.

Incase its releated this is built with twisted 15.4.

dev462 works fine on the same machine.

dev463 works fine on the same machine.

dev470 works fine on the same machine.

dev476 works fine on the same machine.

dev485 works fine on the same machine.

dev492 works fine on the same machine.

dev513 works fine on the same machine.

dev523 breaks on the same machine.

according to my jenkins build these are the commits that changed between those two builds

[Core] Add line numbers to non-dev logging (commit: b754f9f90839fd158d0aa0fef288dff03de5802c) (details)
[GTKUI] Refactor shutdown signal code (commit: 471276716b04415db72954e77c57b1b05ec43dec) (details)
[GTKUI] Refactor rpc stats code (commit: ed6355fe863afc90acc1f27e56786f3f696a2f6e) (details)
[UI] Add Python and OS info to version output (commit: ac09caefac7a33079e536b19f2329ebfd5539121) (details)
[GTKUI] Move imports to top (commit: 0a3404fa5559501586599d27709b52f437011d15) (details)
[GTKUI] Remove old twisted and gnome code (commit: 058b0e41d22b4f62c3edbcf6069793587d7ff8e9) (details)
[GTKUI] Fix open dialogs preventing gtk app closing (commit: fc9bc2976f9a3210774323146366cf8c405a1e00) (details)
[GTKUI] Fix unselect error with treeview selection returning None (commit: c62c60441852ff6b33eb0216729d374892b946f2) (details)
[#2738] [Core] Fix illegal argument with (commit: 27bf05f2fe7b2698816a939f38b5d1a0e22ac07c) (details)
[Core] Remove int casting as args should be int (commit: c796acf79174dc4004f53fd78445260e3a8feaf8) (details)
Last edited 5 years ago by Doadin (previous) (diff)

comment:4 Changed 5 years ago by Doadin

ok i found it https://github.com/doadin/deluge/commit/058b0e41d22b4f62c3edbcf6069793587d7ff8e9#diff-d0a8a088a0b54771b27593e01610186bR420 this portion(lines 420-435) need to be reverted or fixed in a better way. even in twisted 16.1 this code is needed.(not sure its a twisted bug as noted since it would appear this has been needed since twisted 12 and still needed in twisted 16.1.1)

Last edited 5 years ago by Doadin (previous) (diff)

comment:5 Changed 5 years ago by Cas

Thanks for tracking down the issue. I have fixed this in develop: [21789e0692d36]

Placing minor reference to old ticket #2148 here.

comment:6 Changed 5 years ago by Cas

  • Resolution set to Fixed
  • Status changed from new to closed

comment:7 Changed 3 years ago by Cas

  • Milestone changed from 2.0 to 2.0.0

Milestone renamed

Note: See TracTickets for help on using tickets.