Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#2828 closed bug (Fixed)

Missing imports after packaging

Reported by: Doadin Owned by:
Priority: trivial Milestone: 2.0.0
Component: Packaging Version: develop
Keywords: Cc:

Description

with setuptools later then 18.8(reported by other packages see links going from 19.2 to 19.3+)

E:\Program Files (x86)\Deluge>deluged-debug
Traceback (most recent call last):
  File "<string>", line 6, in <module>
  File "__main__.py", line 128, in <module>
  File "__main__deluged-debug__.py", line 5, in <module>
  File "pkg_resources/__init__.py", line 68, in <module>
  File "pkg_resources/extern/__init__.py", line 60, in load_module
ImportError: The 'packaging' package is required; normally this is bundled with this package so if you get this warning, consult the packager of your distribution.

E:\Program Files (x86)\Deluge>deluge-debug
Traceback (most recent call last):
  File "<string>", line 6, in <module>
  File "__main__.py", line 128, in <module>
  File "__main__deluge-debug__.py", line 5, in <module>
  File "pkg_resources/__init__.py", line 68, in <module>
  File "pkg_resources/extern/__init__.py", line 60, in load_module
ImportError: The 'packaging' package is required; normally this is bundled with this package so if you get this warning, consult the packager of your distribution.

https://github.com/pypa/setuptools/issues/517

Change History (9)

comment:1 Changed 5 years ago by Cas

Please do not change the milestone, certainly not to not applicable.

comment:2 Changed 5 years ago by Cas

  • Resolution set to Fixed
  • Status changed from new to closed

There is no point in reporting this issue since it has no bearing on us.

comment:3 Changed 5 years ago by Doadin

I was just aiming for a few things

  1. Make it known that this is a issue for anyone that might run into it.
  2. Present it as a issue here so that a solution could maybe be made.

If you look into the infomation provided in the link i believe someone has posted a workaround for providing compatibility with newer versions maybe something we might want to consider since any new user might run into this(or someone simply installing a fresh system).

Last edited 5 years ago by Doadin (previous) (diff)

comment:4 Changed 5 years ago by Cas

What is the workaround? If it does not involve Deluge code then I'm afraid it is irrelevant here.

Last edited 5 years ago by Cas (previous) (diff)

comment:5 Changed 5 years ago by Doadin

I believe somethig like this could be adapted maybe

comment:6 Changed 5 years ago by Doadin

at the very least maybe change the wiki to pip install setuptools==18.8?

comment:7 Changed 5 years ago by Cas

  • Milestone changed from not applicable to 2.0
  • Resolution Fixed deleted
  • Status changed from closed to reopened
  • Version changed from other (please specify) to develop (git)

Ah so this is an issue in packaging with bbfreeze script, then it has become our problem as bbfreeze is unmaintained now...

comment:8 Changed 5 years ago by Cas

  • Resolution set to Fixed
  • Status changed from reopened to closed

Fixed in develop: [6971e08b0] and 1.3-stable: [1a11e085b27]

comment:9 Changed 2 years ago by Cas

  • Milestone changed from 2.0 to 2.0.0

Milestone renamed

Note: See TracTickets for help on using tickets.