Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2836 closed bug (Invalid)

webui returns blank page when used with --base

Reported by: mbaran Owned by:
Priority: major Milestone: needs verified
Component: Web UI Version: develop
Keywords: --base proxy Cc: Cas


This is in reference to closed ticket

I am running latest develop branch which includes the commits to fix this issue.

When configured as such (using --base or setting base in web.conf) I get nothing but a blank page when browsing to the web site.

I've tested the site in IE, FF, Chrome, and Edge, all have the same issue.

I can privately provide a URL which is publicly accessible for verification.

Change History (5)

comment:1 Changed 8 years ago by bro

To be able to reproduce the issue we need as much detailed information as possible. That includes the exact command you run as well as the URL you try to access.

comment:2 Changed 8 years ago by Cas

Are you sure this is not the same as #2807

Version 0, edited 8 years ago by Cas (next)

comment:3 Changed 8 years ago by mbaran

EDIT: I just realized I get nothing even without a base being set. This may be the same as 2807, trying now.

Command I've been testing with is

deluge-web --config=/tmp --base="/deluge" -L debug

Developer console shows an error in Delugr.debug, but only in Chrome, I don't see if in safari.

I've tried the following URL

The TLD is behind a Netscaler VPX using Content Switching/Reverse? Proxy. I use the same device for NZBGet/Sonarr/Couch with no issues.

The Netscaler also provides SSL Offloading, so the back end connection is http. Aside from Netscaler issues, I would expect the IP address to work.

I've also tried sending the X-Deluge-Base header to no avail.

Last edited 8 years ago by mbaran (previous) (diff)

comment:4 Changed 8 years ago by mbaran

  • Resolution set to Invalid
  • Status changed from new to closed

sorry, this was #2807 getting me. It was late and I had never tested without the base to realize I had no WebUI no matter what.

comment:5 Changed 8 years ago by Cas

Either using develop install or run minify script should work:

Note: See TracTickets for help on using tickets.