Opened 5 years ago

Closed 5 years ago

#2852 closed bug (Fixed)

Set lt version upper limit to 1.0

Reported by: Cas Owned by:
Priority: major Milestone: 1.3.13
Component: Core Version: 1.3.12
Keywords: Cc:

Description


Change History (5)

comment:1 Changed 5 years ago by Cas

For libtorrent 1.1 there are many methods removed for settings etc. that will result in Deluge 1.3 crashing. We will not be adding support for it to 1.3.x series as the changes required are non-trivial.

So the maximum version for libtorrent needs to be set to 1.0.x.

comment:2 Changed 5 years ago by andar

Maybe we should consider doing a 1.4.0 release soonish? Do we have a list of current blockers? Is libtorrent 1.1 support one of them?

comment:3 Changed 5 years ago by Cas

I hadn't got around to adding lt 1.1 support ticket to 2.0 roadmap but setting it to 1.1 as minimum was going to be the next task anyway. Also still working towards that release with all those tickets needing completed.

comment:4 Changed 5 years ago by bro

I've tried to look at libtorrent 1.1, but I it segfaults when loading torrents. Not sure if it's the python bindings or something else.

comment:5 Changed 5 years ago by Cas

  • Resolution set to Fixed
  • Status changed from new to closed

Fixed in 1.3-stable: [852b51f224]

Note: See TracTickets for help on using tickets.