Opened 3 years ago

Last modified 3 years ago

#2903 new bug

Torrent List Does not properly update

Reported by: Taintain Owned by:
Priority: minor Milestone: needs verified
Component: GTK UI Version: 1.3.13
Keywords: UI Update Cc:

Description

I'm running on Windows 10.

For quite a while now the main torrent window has not been always displaying the accurate torrents. It will have some missing, and I can't figure out what causes this. If a torrent is missing in one filter, it will be missing in all of them.

Switching back and forth between Filter options seems to sometimes fix it, it doesn't seem to be tied to how long the program has been running. Switching between filters that should & shouldn't have the torrent seems to work best (Downloading and Paused).

deluged.log doesn't show any output.

I've attached two screenshots to hopefully explain what I mean clearly.

Attachments (2)

Untitled.png (13.7 KB) - added by Taintain 3 years ago.
Untitled2.png (31.8 KB) - added by Taintain 3 years ago.

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by Taintain

Changed 3 years ago by Taintain

comment:1 Changed 3 years ago by Cas

What is shown is the WebUI? Does disabling plugins change anything? Have you tried in thinclient mode?

comment:2 Changed 3 years ago by Taintain

WebUI seems to work as intended, at least is more stable than the GTK UI, messing with the filters for a few minutes didn't break it.

Disabling plugins doesn't change behavior.

Turning on classic mode didn't change anything. If thinclient means something else let me know and I can try that.

Note: See TracTickets for help on using tickets.