Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#293 closed bug (Fixed)

add torrent broken

Reported by: danii Owned by: andar
Priority: blocker Milestone:
Component: Core Version: 1.1.0_dev
Keywords: add torrent Cc:

Description

Deluge 0.6.0.0r3270

adding a new torrent fails with:

[DEBUG   ] 17:54:05 client:204 Attempting to add torrent files: ['/mnt/series/temp/b174.torrent']
[WARNING ] 17:54:05 client:100 Could not contact daemon: <Fault 1: "exceptions.AttributeError:Torrent instance has no attribute 'stop_ratio'">
[INFO    ] 17:54:05 client:110 Setting core uri as None
[DEBUG   ] 17:54:05 component:137 Stopping component SystemTray..
[DEBUG   ] 17:54:05 component:137 Stopping component PluginManager..
[DEBUG   ] 17:54:05 component:137 Stopping component Preferences..
[DEBUG   ] 17:54:05 component:137 Stopping component DbusInterface..
[DEBUG   ] 17:54:05 component:137 Stopping component StatusBar..
[DEBUG   ] 17:54:05 component:137 Stopping component AddTorrentDialog..
[DEBUG   ] 17:54:05 component:137 Stopping component ConnectionManager..
[DEBUG   ] 17:54:05 component:137 Stopping component TorrentView..
[DEBUG   ] 17:54:05 component:137 Stopping component Signals..
[DEBUG   ] 17:54:05 signalreceiver:72 Unable to deregister client from server: 'The core proxy is invalid.'
[DEBUG   ] 17:54:05 signalreceiver:74 Shutting down signalreceiver
[DEBUG   ] 17:54:05 signalreceiver:77 Joining listening thread..
[DEBUG   ] 17:54:05 component:137 Stopping component TorrentDetails..
[DEBUG   ] 17:54:05 configmanager:88 Getting config 'gtkui.conf'
[DEBUG   ] 17:54:05 files_tab:201 Saving FilesTab state file: files_tab.state
[DEBUG   ] 17:54:05 configmanager:88 Getting config 'gtkui.conf'
[DEBUG   ] 17:54:05 peers_tab:161 Saving FilesTab state file: peers_tab.state
[DEBUG   ] 17:54:05 configmanager:88 Getting config 'gtkui.conf'
[DEBUG   ] 17:54:05 torrentdetails:289 Saving TorrentDetails state file: tabs.state
[DEBUG   ] 17:54:05 component:137 Stopping component CoreConfig..
[DEBUG   ] 17:54:05 component:137 Stopping component SideBar..
[DEBUG   ] 17:54:05 component:137 Stopping component QueuedTorrents..
[DEBUG   ] 17:54:05 component:137 Stopping component MainWindow..
[DEBUG   ] 17:54:05 component:137 Stopping component ToolBar..
[DEBUG   ] 17:54:05 component:137 Stopping component MenuBar..

this is with a clean config

Change History (15)

comment:1 Changed 12 years ago by andar

This sounds like your client/daemon versions are out-of-sync.

comment:2 Changed 12 years ago by danii

  • Component changed from gtkui to core

ok, I always kill all instances of deluge before trying a new version, tried the web ui and the error is the same, so it seems like a core problem, also I've tested several torrents so the problem isn't the torrent itself, just to be sure I tested again with a clean config still fails

comment:3 Changed 12 years ago by danii

  • Resolution set to fixed
  • Status changed from new to closed

fixed in [3276]

comment:4 Changed 12 years ago by anonymous

  • Milestone 0.6.0 deleted

Milestone 0.6.0 deleted

comment:5 Changed 12 years ago by anonymous

I have the same problem with the new RC2 version. It happens only on 1 tracker (witch worked OK before)

comment:6 follow-up: Changed 12 years ago by andar

Is it the same error message?

comment:7 in reply to: ↑ 6 Changed 12 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 0.6.0svn to 0.9.02 (1.0.0_RC2)

Yes.

Exacly the same

comment:8 Changed 12 years ago by andar

I cannot reproduce this problem and can't really see how it would be triggered in the code. Does this happen every time you try to add a torrent, or just with specific torrents?

comment:9 Changed 12 years ago by anonymous

It happen only if i add torrent from one specific private tracker (the old versions worked fine )

comment:10 Changed 12 years ago by andar

Could you send me the torrent? andrewresch@…

comment:11 Changed 12 years ago by danii

  • Milestone set to 1.0.0

are you using Python 2.4? this was happening to me, but it got fixed with [3481]

comment:12 Changed 12 years ago by anonymous

No. Im using 2.5. Should i use 2.4? I dont realy understand much about the link you posted.

comment:13 Changed 12 years ago by anonymous

  • Version changed from 0.9.02 (1.0.0_RC2) to 1.1.0_dev

Having a similar problem.

Using GTK interface, version 1.1.0-devr3748.

Add torrent, add dialogue pops up, seems to work.

Torrent doesn't show up in GUI.

Shut down GUI (NOT daemon), restart GUI, torrent is there.

Tried starting torrent paused, not paused, same problem.

Also tried private, not private tracker - same problem.

I think the bug appeared sometime in last week of svn versions, but not sure exactly when.

No errors in deluged log, wasn't logging gtk log when last happened.

Details: deluge version 1.1.0-devr3748 System: Ubuntu, Hardy 8.08, all updates installed, kernel 2.6.24.21-386 Python: v2.5.2

comment:14 Changed 12 years ago by andar

  • Resolution set to fixed
  • Status changed from reopened to closed

This has been fixed in svn.

comment:15 Changed 12 years ago by anonymous

  • Milestone 1.0.0 deleted

Milestone 1.0.0 deleted

Note: See TracTickets for help on using tickets.