Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#2945 closed bug (WontFix)

autoadd torrent broken with systemd service

Reported by: graysky Owned by:
Priority: minor Milestone: 1.3.14
Component: Core Version: 1.3.13
Keywords: Cc:

Description

Summary: I am running deluged via the distro provided systemd service (which I attached to this ticket for reference). Deluged is configured to "auto add .torrents from: /mnt/share/Downloads" but it only adds one torrent from that directory. If I download additional ones or if additional ones are in that directory, it does not take any action.

Upon adding the torrent, journalctl shows a single line:

Nov 29 07:14:21 seedbox deluged[702]: Unhandled error in Deferred:

If I stop the systemd service and run deluged as my user, all torrent files are detected and added and nothing is written to ~/.config/deluge/deluge.log

Version of deluge: I am running the official Arch Linux package which is 1.3.13+2+g6c73105

Attachments (2)

deluged.service (156 bytes ) - added by graysky 8 years ago.
journalctl_with_debug_logging.log (41.9 KB ) - added by graysky 8 years ago.

Download all attachments as: .zip

Change History (10)

by graysky, 8 years ago

Attachment: deluged.service added

comment:1 by graysky, 8 years ago

I just built from the github 1.3-stable branch (5f92810) and am experiencing the same.

Nov 29 07:44:04 seedbox systemd[1]: Started Deluge Daemon.
Nov 29 07:44:05 seedbox deluged[1042]: /usr/lib/python2.7/site-packages/deluge/_libtorrent.py:59: RuntimeWarning: to-Python converter for boost::shared_ptr<libtorrent::alert> already registered; second conversion method ignored.
Nov 29 07:44:05 seedbox deluged[1042]:   import libtorrent as lt
Nov 29 07:44:05 seedbox deluged[1042]: Unhandled error in Deferred:

comment:2 by graysky, 8 years ago

I updated deluged.service to include the debug switch and have attached the corresponding journalctl output (journalctl_with_debug_logging.log). Note that I started deluged.service with 5 torrent files in the watched directory but only 1 of them as added; you see the "Unhandled error in Deferred" at line 301.

by graysky, 8 years ago

comment:3 by Calum, 8 years ago

Milestone: needs verified1.3.14

I will need to investigate this further myself as the log doesn't really identify the actual issue :/

comment:4 by Jeff, 7 years ago

Confirmed behavior in Ubuntu 1.3.13-0~xenial~ppa1. In previous versions, the torrent file was also deleted after autoadd. Now I've noticed that it picks up the last one, and then stops without deleting. It seems like a permissions issue, but still doesn't work when explicitly set to 666.

comment:5 by Calum, 7 years ago

Can you enable deluged logging to get a proper error trace: Troubleshooting

Version 0, edited 7 years ago by Calum (next)

comment:6 by Jeff, 7 years ago

I worked around the problem by installing the AutoAdd plugin, and then initializing it from the gtk desktop client on another machine. From there, I noticed it threw me an error message noting that the deluge user needed explicit rights to the folder. It's been a while, but I believe I chmod 775 -R downloads/ && chown :deluge -R downloads/ fixed that and it's been working fine. I haven't gone back to test the regular autoadd from downloads that led me to that point. If it's needed, then I can test again if you'd like. Not sure if OP resolved issue or not.

comment:7 by Calum, 7 years ago

Component: UnknownCore
Resolution: WontFix
Status: newclosed
Version: other (please specify)1.3.13

Ah I see, it's not the plugin, it's the built-in code.

Permission issue would sound correct, it would need write permissions to delete or rename the files.

I don't think I will investigate this further as it's obsolete code (removed in develop) and I always recommend using the AutoAdd plugin anyway.

comment:8 by graysky, 7 years ago

@admonkey - No, I haven't resolved the issue. I will try the plugin recommended in this ticket as a solution.

Note: See TracTickets for help on using tickets.