Opened 16 years ago

Closed 16 years ago

#295 closed bug (WorksForMe)

Deluge not downloading complete blocks

Reported by: Owned by: markybob
Priority: critical Milestone:
Component: 0.5.x Version:
Keywords: Cc:


This is the issue explained here:

Deluge is not completing the blocks during downloading any torrents, leading to much smaller file completion reports than overall completion, difficulty in seeding, and potential huge data loss on any recheck. (Which happened to me once)

Probably the same bug also means files marked "Highest" are not much faster to download than others, or at least take much longer than they did before.

Possibly this is a new/'improved' parts selecting algorithm?

(I have submitted this under "critical", as I believe it is a critical issue, however I am unfamiliar with this system, so please change it if you do not agree.)

Change History (9)

comment:1 Changed 16 years ago by

Also in the forum, but not in my post: Deluge seems to complete parts for a few seconds when it first opens. That is, file completion statuses will suddenly jump up by several blocks. However this still does not approach the actual amount downloaded overall.

comment:3 Changed 16 years ago by anonymous

I can confirm this with On ubuntu hardy. On a big torrent download, it's like I start anew every day... That's endless...

comment:4 Changed 16 years ago by anonymous

Another confirmation.

This is a huge bug. I just lost 20gigs on a torrent. :( Hardy

comment:5 Changed 16 years ago by David Hammond

I'm still experiencing the data loss issue in 0.9.03 on Ubuntu Hardy. Since I'm not noticing the discrepancy between the torrent progress and the file progress, I'm not sure if this is the same issue or a different (similar) one.

Due to power failures, I've had my computer unexpectedly reboot about once a day for the last few days. Each day, the torrent has gone from about 30% to 60%, and then when a power failure happens it goes back to about 30%. So in the last few days I have effectively had zero progress on this torrent. I have also experienced data loss when closing Deluge normally and reopening it, as well as when rechecking. I just now tried a force re-check on a torrent with 22% progress, and it now says the progress is only 4.7%.

I also notice that individual files sit at about 90% for ages. Within a single torrent, I set one file to "Highest" priority, another to "High" priority, and the rest to "Normal" priority. The "Highest" priority file went up to around 90% and then more or less stayed there. The "High" priority file then went up to around 90% and also stopped increasing much. Now, all of the files in the torrent are around 90%, and yet neither the "Highest" nor "High" priority files have completed. The torrent has very good availability. I also notice that if I set all files but one to "Do Not Download", it will eventually finish, but it still seems to take a disproportionately long time to finish once it nears 90%.

Personally, I think this bug should block the 1.0.0 release. The bug didn't used to exist, and it has rendered Deluge extremely unreliable for me.

comment:6 Changed 16 years ago by

Just another confirmation of this bug. I'm also using Ubuntu Hardy & Deluge 0.9.3, with Full Allocation enabled (not sure if it's relevant, but I figure since it is something to do with the downloaded blocks, it might be relevant).

comment:7 Changed 16 years ago by

Confirmed on Deluge 0.94 Hardy-amd64. Huge amounts of data can be lost. Step to reproduce kill Deluge during a download reload deluge to find download at 0%

comment:8 Changed 16 years ago by

  • Version changed from to

I've gone back to the Ubuntu Hardy LTS offering to attempt to get past this problem...lost 100s of gig..tried everything available through UI...tried other so called improved builds...same issues...resorting back to which now has "issues" with the ratio tab

in Compact allocation Deluge appeared to take on the previous downloaded amount as the starting point for the next session...seemingly dumping the rest of the data previously acquired...but even that was inconsistent in sorts...some torrents would go along happily to completion whereas as others would self Force Recheck and start at ground aero again...or any random between AND sometimes end a 100% Recheck only to start again then bork into inactivity in figures under 10% and the only remedy apparently possible is to remove, as in -rm, then start over.

Even cnp-ing states of downloaded and reloading remedied nothing

comment:9 Changed 16 years ago by mvoncken

  • Resolution set to worksforme
  • Status changed from new to closed

Worksforme in 1.1 : Closing old bugs, feel free to reopen.

Note: See TracTickets for help on using tickets.