Opened 7 years ago

Last modified 16 months ago

#2972 new bug

deluge-web and deluge-gtk refuse to connect to a daemon which has autoadd_enable set to true

Reported by: Karl Richter Owned by:
Priority: minor Milestone: needs verified
Component: Web UI Version: 2.1.0
Keywords: Cc: cmcologne


If autoadd_enable is set to true in core.conf in deluged configuration, deluge-web doesn't connect to it any more. deluged starts as expected and adds all torrents in the auto-add directory. One has to guess when it's finished, stop it, edit the configuration file and start it in order to allow deluge-web to connect. deluge-web sets the value back to true at every start.

There's no feedback in the GUI, console output or log files with log priority debug which indicates a severe misconception of feedback.

deluge-web log at and deluged log at

Change History (6)

comment:1 by Karl Richter, 7 years ago

I triggered this issue twice by changing autoadd_enable, but apparently that was due to random behaviour - impossible to tell without feedback. The specified reason seems to be not or only partially the reason of the problem.

comment:3 by Calum, 7 years ago

Have you tried connecting with deluge-console locally and remotely?

Last edited 7 years ago by Calum (previous) (diff)

comment:4 by Karl Richter, 7 years ago

Have you tried connecting with deluge-console locally and remotely?

>>> connect                                                     
>>> info                                                                        
Not connected to a daemon, please use the connect command first.

although deluged is running:

> sudo netstat -tupln | grep 58846
tcp       28      0 *               LISTEN      14815/python
> sudo systemctl status deluged.service
● deluged.service - LSB: Start or stop the Deluge BitTorrent daemon.
   Loaded: loaded (/etc/init.d/deluged; generated; vendor preset: enabled)
   Active: active (running) since Mo 2017-02-20 04:57:59 CET; 19h ago
     Docs: man:systemd-sysv-generator(8)
  Process: 14746 ExecStop=/etc/init.d/deluged stop (code=exited, status=0/SUCCES
  Process: 14797 ExecStart=/etc/init.d/deluged start (code=exited, status=0/SUCC
    Tasks: 5 (limit: 4915)
   Memory: 51.5M
      CPU: 3.757s
   CGroup: /system.slice/deluged.service
           └─14815 /usr/bin/python /usr/bin/deluged -d -c /var/lib/deluge/deluge

Warning: Journal has been rotated since unit was started. Log output is incomple

comment:5 by Karl Richter, 7 years ago

The issue was fixed once after a reboot, but I could reproduce it 3 times after a reboot, so the reboot seems to have triggered something that fixes the issue, maybe a race condition.

comment:6 by cmcologne, 16 months ago

Cc: cmcologne added

I have currently this bug in version 2.1.0. Deluge is running remotely as daemon. Communication between thinclient and daemon freezes, when i put files in to the watch folder. As soon as the torrent files are processed, there is communication between thinclient and daemon back online.

Note: See TracTickets for help on using tickets.