#2978 closed bug (Fixed)

gtk bloking

Reported by: firefox Owned by:
Priority: blocker Milestone: 2.0
Component: GTK UI Version: develop (git)
Keywords: Cc:

Description

Latest build does not start. the deluged is ok , you can logon webui but the gtk is bloked, i only have a screen shot og the error, will send that sorry !!!

Change History (22)

comment:1 Changed 14 months ago by firefox

Traceback (most recent call last):
  File "/usr/bin/deluge", line 9, in <module>
    load_entry_point('deluge==2.0.0.dev6961', 'gui_scripts', 'deluge')()
  File "/usr/lib/python2.7/dist-packages/deluge/ui/ui_entry.py", line 53, in start_ui
    parser = add_ui_options_group(BaseArgParser())
  File "/usr/lib/python2.7/dist-packages/deluge/ui/baseargparser.py", line 167, in __init__
    super(BaseArgParser, self).__init__(*args, **kwargs)
  File "/usr/lib/python2.7/argparse.py", line 1597, in __init__
    self._positionals = add_group(_('positional arguments'))
  File "/usr/lib/python2.7/gettext.py", line 584, in gettext
    return dgettext(_current_domain, message)
  File "/usr/lib/python2.7/gettext.py", line 548, in dgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib/python2.7/gettext.py", line 496, in translation
    t = _translations.setdefault(key, class_(fp))
  File "/usr/lib/python2.7/gettext.py", line 182, in __init__
    self._parse(fp)
  File "/usr/lib/python2.7/gettext.py", line 340, in _parse
    tmsg = unicode(tmsg, self._charset)
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xa0 in position 0: invalid start byte
Last edited 14 months ago by Cas (previous) (diff)

comment:2 Changed 14 months ago by Cas

  • Milestone changed from 2.0.x to 2.0

Hmm I cannot replicate here.

What is your OS version?

Also what is the output of locale?

Does it work if you try: LANGUAGE=en deluge

Last edited 14 months ago by Cas (previous) (diff)

comment:3 Changed 14 months ago by firefox

Ubuntu 16.10... same on raspberry .

comment:4 Changed 14 months ago by firefox

Neither language=enjoy deluge. Same error

comment:5 Changed 14 months ago by firefox

Ops. Language=en 😂😂

comment:6 Changed 14 months ago by firefox

Deleted the deluge folder in .config . No changes. Still crash. Removed and reinstalled. Same error. Previous build installed works fine .. so must be in the latest build.

comment:7 Changed 14 months ago by Cas

Yes it's something to do with the unicode_literals commit but I don't know exactly what so I need to replicate and I have tested on 16.10.

Are you saying that LANGUAGE=en deluge did not work? Can you also try LC_ALL='en_US.UTF-8' deluge

What is the output of locale

comment:8 Changed 14 months ago by firefox

$ `LC_ALL='en_US.UTF-8' deluge`
Traceback (most recent call last):
  File "/usr/bin/deluge", line 9, in <module>
    load_entry_point('deluge==2.0.0.dev6961', 'gui_scripts', 'deluge')()
  File "/usr/lib/python2.7/dist-packages/deluge/ui/ui_entry.py", line 53, in start_ui
    parser = add_ui_options_group(BaseArgParser())
  File "/usr/lib/python2.7/dist-packages/deluge/ui/baseargparser.py", line 167, in __init__
    super(BaseArgParser, self).__init__(*args, **kwargs)
  File "/usr/lib/python2.7/argparse.py", line 1597, in __init__
    self._positionals = add_group(_('positional arguments'))
  File "/usr/lib/python2.7/gettext.py", line 584, in gettext
    return dgettext(_current_domain, message)
  File "/usr/lib/python2.7/gettext.py", line 548, in dgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib/python2.7/gettext.py", line 496, in translation
    t = _translations.setdefault(key, class_(fp))
  File "/usr/lib/python2.7/gettext.py", line 182, in __init__
    self._parse(fp)
  File "/usr/lib/python2.7/gettext.py", line 340, in _parse
    tmsg = unicode(tmsg, self._charset)
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xa0 in position 0: invalid start byte
Last edited 14 months ago by Cas (previous) (diff)

comment:9 Changed 14 months ago by firefox

$ locale
LANG=it_IT.UTF-8
LANGUAGE=it_IT
LC_CTYPE="it_IT.UTF-8"
LC_NUMERIC="it_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_COLLATE="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL=
Last edited 14 months ago by Cas (previous) (diff)

comment:10 Changed 14 months ago by firefox

$ LC_ALL='it_IT.UTF-8' deluge`
Traceback (most recent call last):
  File "/usr/bin/deluge", line 9, in <module>
    load_entry_point('deluge==2.0.0.dev6961', 'gui_scripts', 'deluge')()
  File "/usr/lib/python2.7/dist-packages/deluge/ui/ui_entry.py", line 53, in start_ui
    parser = add_ui_options_group(BaseArgParser())
  File "/usr/lib/python2.7/dist-packages/deluge/ui/baseargparser.py", line 167, in __init__
    super(BaseArgParser, self).__init__(*args, **kwargs)
  File "/usr/lib/python2.7/argparse.py", line 1597, in __init__
    self._positionals = add_group(_('positional arguments'))
  File "/usr/lib/python2.7/gettext.py", line 584, in gettext
    return dgettext(_current_domain, message)
  File "/usr/lib/python2.7/gettext.py", line 548, in dgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib/python2.7/gettext.py", line 496, in translation
    t = _translations.setdefault(key, class_(fp))
  File "/usr/lib/python2.7/gettext.py", line 182, in __init__
    self._parse(fp)
  File "/usr/lib/python2.7/gettext.py", line 340, in _parse
    tmsg = unicode(tmsg, self._charset)
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xa0 in position 0: invalid start byte
Last edited 14 months ago by Cas (previous) (diff)

comment:11 Changed 14 months ago by Cas

Ok thanks for the update. Please use the code tags {{{ }}} to nicely format console output.

comment:12 Changed 14 months ago by Cas

  1. What do you get if you try to run deluge-console or deluge-gtk?
  2. What is the output of python -c 'import sys; print(sys.getdefaultencoding())'
  3. Do you know which git commit causes this?
  4. Could you try removing the following line from deluge/ui/translations_util.py:
    from __future__ import unicode_literals
    

comment:13 Changed 14 months ago by firefox

renato@renato-desktop:~$ deluge-console Traceback (most recent call last):

  File "/usr/bin/deluge-console", line 9, in <module>
    load_entry_point('deluge==2.0.0.dev6961', 'console_scripts', 'deluge-console')()
  File "/usr/lib/python2.7/dist-packages/deluge/ui/console/__init__.py", line 19, in start
    Console().start()
  File "/usr/lib/python2.7/dist-packages/deluge/ui/console/console.py", line 67, in __init__
    super(Console, self).__init__('console', *args, log_stream=LogStream(), **kwargs)
  File "/usr/lib/python2.7/dist-packages/deluge/ui/ui.py", line 40, in __init__
    self.__parser = BaseArgParser(**kwargs)
  File "/usr/lib/python2.7/dist-packages/deluge/ui/baseargparser.py", line 167, in __init__
    super(BaseArgParser, self).__init__(*args, **kwargs)
  File "/usr/lib/python2.7/argparse.py", line 1597, in __init__
    self._positionals = add_group(_('positional arguments'))
  File "/usr/lib/python2.7/gettext.py", line 584, in gettext
    return dgettext(_current_domain, message)
  File "/usr/lib/python2.7/gettext.py", line 548, in dgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib/python2.7/gettext.py", line 496, in translation
    t = _translations.setdefault(key, class_(fp))
  File "/usr/lib/python2.7/gettext.py", line 182, in __init__
    self._parse(fp)
  File "/usr/lib/python2.7/gettext.py", line 340, in _parse
    tmsg = unicode(tmsg, self._charset)
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xa0 in position 0: invalid start byte
renato@renato-desktop:~$ }}}




renato@renato-desktop:~$ deluge-gtk
Traceback (most recent call last):
  File "/usr/bin/deluge-gtk", line 9, in <module>
    load_entry_point('deluge==2.0.0.dev6961', 'gui_scripts', 'deluge-gtk')()
  File "/usr/lib/python2.7/dist-packages/deluge/ui/gtkui/__init__.py", line 50, in start
    Gtk().start()
  File "/usr/lib/python2.7/dist-packages/deluge/ui/gtkui/__init__.py", line 25, in __init__
    super(Gtk, self).__init__('gtk', *args, description='Starts the Deluge GTK+ interface', **kwargs)
  File "/usr/lib/python2.7/dist-packages/deluge/ui/ui.py", line 40, in __init__
    self.__parser = BaseArgParser(**kwargs)
  File "/usr/lib/python2.7/dist-packages/deluge/ui/baseargparser.py", line 167, in __init__
    super(BaseArgParser, self).__init__(*args, **kwargs)
  File "/usr/lib/python2.7/argparse.py", line 1597, in __init__
    self._positionals = add_group(_('positional arguments'))
  File "/usr/lib/python2.7/gettext.py", line 584, in gettext
    return dgettext(_current_domain, message)
  File "/usr/lib/python2.7/gettext.py", line 548, in dgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib/python2.7/gettext.py", line 496, in translation
    t = _translations.setdefault(key, class_(fp))
  File "/usr/lib/python2.7/gettext.py", line 182, in __init__
    self._parse(fp)
  File "/usr/lib/python2.7/gettext.py", line 340, in _parse
    tmsg = unicode(tmsg, self._charset)
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xa0 in position 0: invalid start byte
renato@renato-desktop:~$ 


renato@renato-desktop:~$ python -c 'import sys; print(sys.getdefaultencoding())'ascii
renato@renato-desktop:~$ 

the prob is on deluge==2.0.0.dev6961

comment:14 Changed 14 months ago by firefox

Could you try removing the following line from deluge/ui/translations_util.py:

from future import unicode_literals

same output.

comment:15 Changed 14 months ago by firefox

Ps i am using the ppa

comment:16 Changed 14 months ago by firefox

Btw in the deluge for there are .pyc files. I changed the. Py as I said. Maybe will take no effect because that ?

comment:17 Changed 14 months ago by firefox

If I run deluged I can see the interface from web .

comment:18 Changed 14 months ago by Cas

Yes the webui plugin would be unaffected. I know roughly what the issue is but without being able to replicate it will be hard to fix. I have some more changes that may fix this but I've not quite finished that branch...

comment:19 Changed 14 months ago by firefox

I understand that.. anyone else had this problem ? If you want we can have a test in the afternoon I have time if you need more info...

comment:20 Changed 14 months ago by firefox

ok i removed all from the ppa, pulled down from git compiled installed and working ! so the problem is on the ppa version ... till dev 6936 from the ppa all is ok, with 6961 it's impossible to load, btw there is troubles with webui on the latest build, web ui fails utf8

comment:21 Changed 13 months ago by Cas

Should be fixed for the next ppa build tomorrow: #2993

comment:22 Changed 13 months ago by Cas

  • Resolution set to Fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.