Opened 2 years ago

Last modified 4 weeks ago

#2980 reopened bug

New torrents not getting location settings properly applied

Reported by: KingSizedKilla Owned by:
Priority: minor Milestone: 1.3.16
Component: Plugin Version: 1.3.13
Keywords: label Cc:

Description

I am using Deluge on Ubuntu and have labels that are configured to move completed torrents to a NAS share on a DROBO that is open to everyone with read/write permissions. Existing torrents will move fine, but when new torrents are added I need to edit the label by turning off the move function and then turning it back on to get the functionality to resume working. However, new torrents that get added after turning the function back on do not pick up that they are supposed to move, even though they have been properly labeled. The torrents are automatically added by Sickrage and I can see that the label gets properly applied by Deluge. But the only way that the torrents will move automatically as they should is if I disable and then re-enable the functionality. I have even deleted and recreated the label and the same behavior exists.

Change History (11)

comment:1 Changed 2 years ago by KingSizedKilla

I have observed that new movie torrents are getting the movie label applied properly and are getting moved after completion every time, unlike the torrents that get the tv label applied. The location is on the same device and the folders each have the same permissions

comment:2 Changed 2 years ago by painy

I'm having a similar problem: I use Deluge, Sickrage and Couchpotato on Docker on a Synology NAS

Movies are added via a blackhole and are moved to the folder '/docker/deluge/downloads/complete/movies'. This works fine

Tv shows are added via sickrage with the label 'tvshows'. I've got the label plugin set up to move files with the 'tvshows' label to '/docker/deluge/downloads/complete/tvshows'. When I manually add a torrent and add the 'tvshows' label the completed download moves to the '/docker/deluge/downloads/complete/tvshows' folder.

When Sickrage adds the file the 'tvshows' label is added correctly but the move folder is set to /docker/deluge/downloads/. If i remove and readd the label, the move folder is set to '/docker/deluge/downloads/complete/tvshows'

I removed and re-configured the plugin but the problem remains

comment:3 Changed 2 years ago by Cas

Could it be that the label and move completed are both set when adding the torrent via sickrage?

comment:4 Changed 2 years ago by KingSizedKilla

Shouldn't that be expected behavior? The option to Move Completed gets set when the label is applied in Deluge

comment:5 follow-up: Changed 2 years ago by Cas

I am postulating that if in torrent options you are setting both label and move_completed I don't know which would be honoured first...

comment:6 in reply to: ↑ 5 Changed 2 years ago by painy

Cas: I've tested and it looks like you found cause of my problem. In Sickrage there is an option in the deluge settings that lets you select the download folder (option 'Downloaded files location: where Deluge will save downloaded files (blank for client default)').

I've left this blanc because in the Docker Volume mount path for Sickrage I had set '/docker/deluge/downloads/complete/tvshows' the default /downloads folder. So in Sickrage it appeared to be the correct folder. The default /downloads folder for Deluge howerver in Docker is deluge/downloads.

I now changed the folder in Sickrage manually to '/docker/deluge/downloads/complete/tvshows' and it works like a charm!

Thanks a bunch Cas! Hope this solves your problem as well KingSK

comment:7 Changed 2 years ago by KingSizedKilla

I actually had the path set in Sickrage, the same as in the label options in Deluge. I have done the opposite and removed this path to see if it makes a difference. I will update once I've had a chance to test

comment:8 Changed 2 years ago by KingSizedKilla

I just verified what painy wrote earlier today. A couple tv show torrents completed overnight and were moved to the appropriate directory after completion.

comment:9 Changed 2 years ago by Cas

  • Milestone changed from needs verified to 1.3.16

Excellent, I am not sure what the solution will be for this but at least it's documented ;)

comment:10 Changed 4 weeks ago by int3l

  • Resolution set to Fixed
  • Status changed from new to closed

comment:11 Changed 4 weeks ago by Cas

  • Resolution Fixed deleted
  • Status changed from closed to reopened

Not fixed!

Note: See TracTickets for help on using tickets.