Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#2993 closed bug (Fixed)

deluge-web fails due to "UnicodeDecodeError: 'utf8' codec can't decode byte 0xc3 in position 18: unexpected end of data"

Reported by: krichter Owned by:
Priority: minor Milestone: 2.0.0
Component: Web UI Version: develop
Keywords: Cc:

Description

After switching to the development PPA ppa:deluge-team/develop deluge-web crashes with

> sudo python -m pdb /usr/bin/deluge-web 
> /usr/bin/deluge-web(3)<module>()
-> __requires__ = 'deluge==2.0.0.dev6963'
(Pdb) c
Traceback (most recent call last):
  File "/usr/lib/python2.7/pdb.py", line 1314, in main
    pdb._runscript(mainpyfile)
  File "/usr/lib/python2.7/pdb.py", line 1233, in _runscript
    self.run(statement)
  File "/usr/lib/python2.7/bdb.py", line 400, in run
    exec cmd in globals, locals
  File "<string>", line 1, in <module>
  File "/usr/bin/deluge-web", line 3, in <module>
    __requires__ = 'deluge==2.0.0.dev6963'
  File "/usr/lib/python2.7/dist-packages/deluge/ui/web/__init__.py", line 7, in start
    web = Web()
  File "/usr/lib/python2.7/dist-packages/deluge/ui/web/web.py", line 27, in __init__
    super(Web, self).__init__('web', *args, description='Starts the Deluge Web interface', **kwargs)
  File "/usr/lib/python2.7/dist-packages/deluge/ui/ui.py", line 40, in __init__
    self.__parser = BaseArgParser(**kwargs)
  File "/usr/lib/python2.7/dist-packages/deluge/ui/baseargparser.py", line 167, in __init__
    super(BaseArgParser, self).__init__(*args, **kwargs)
  File "/usr/lib/python2.7/argparse.py", line 1597, in __init__
    self._positionals = add_group(_('positional arguments'))
  File "/usr/lib/python2.7/gettext.py", line 584, in gettext
    return dgettext(_current_domain, message)
  File "/usr/lib/python2.7/gettext.py", line 548, in dgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib/python2.7/gettext.py", line 496, in translation
    t = _translations.setdefault(key, class_(fp))
  File "/usr/lib/python2.7/gettext.py", line 182, in __init__
    self._parse(fp)
  File "/usr/lib/python2.7/gettext.py", line 340, in _parse
    tmsg = unicode(tmsg, self._charset)
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xc3 in position 18: unexpected end of data
Uncaught exception. Entering post mortem debugging
Running 'cont' or 'step' will restart the program
> /usr/lib/python2.7/encodings/utf_8.py(16)decode()
-> return codecs.utf_8_decode(input, errors, True)
(Pdb) input
<read-only buffer ptr 0x7f1de00f5284, size 19 at 0x7f1de011d5f0>
(Pdb) print(input)
HT</b><b>Hinzugef�

The tail Hinzugef� indicates an issue with the german umlaut ü in the word Hinzufügen.

experienced with 2.0.0.dev6963+9666781+201703011947~ubuntu16.10.1

Change History (5)

comment:1 Changed 5 years ago by Cas

Yeah this seems to be a duplicate of #2978

Can you backup and remove de/LC_MESSAGES/deluge.mo and see if it fixes the issue? If it does can you zip and attach the file here.

comment:2 Changed 5 years ago by Cas

  • Milestone changed from needs verified to 2.0
  • Version changed from other (please specify) to develop (git)

comment:3 Changed 5 years ago by Cas

Ok so I found an issue with the mo files being created by msgfmt so I have pushed a fix: [d1daeb4cb0]

It should propagate to develop PPA build sometime tomorrow.

comment:4 Changed 5 years ago by krichter

  • Resolution set to Fixed
  • Status changed from new to closed

This is fixed in PPA version 2.0.0.dev6980+d1daeb4+201703170531~ubuntu16.10.1 on Ubuntu 16.10. Thank you!

comment:5 Changed 3 years ago by Cas

  • Milestone changed from 2.0 to 2.0.0

Milestone renamed

Note: See TracTickets for help on using tickets.