#3014 closed bug (Fixed)

Bug 2990 still not completely fixed

Reported by: Prods Owned by:
Priority: major Milestone: 1.3.15
Component: Unknown Version: 1.3.14
Keywords: Cc:

Description

Hello:

I just tried the fixed version (March 17) of 1.3.14 and while the download issues in bug 2990 appear to be fixed, the file selection and subsequent attempts to invoke the "do not download" option still have issues:

1) Choosing "do not download" for a folder does not work.

2) Choosing "do not download" for files within a folder often requires several attempts to work.

3) Exiting Deluge and restarting it removes all the "do not download" settings on the files chosen.

4) Random crashes when trying to invoke the "do not download" option.

Had to go back to 1.3.12 again as this makes Deluge unusable for my needs.

Change History (6)

comment:1 Changed 16 months ago by Cas

Is this for newly added torrents or existing ones?

comment:2 Changed 16 months ago by Cas

For the record my testing has shown no issues with 1.3-stable code after that commit was made and I tested all your steps.

Also what are the random crashes? Do you have the crash log?

comment:3 Changed 16 months ago by Prods

I had reinstalled 1.3.14 again this morning after filing the above report and tried it yet again, and got exactly the same results.

It was for both new and existing torrents. Yes, there were existing torrents both times I tried 1.3.1.4 after the commit. I probably should have removed them, and then readded the existing ones. However, new torrents were added and the same issues exist.

1) One cannot choose a folder for "do not download." It simply does not work on my machine. You can right-click and choose it on the menu, but it does not invoke "do not download" on the files in the folder no matter how many times one tries. 2) Multiple tries are often necessary to get files to show that "do not download" is invoked ... it may work the first time, or it may take half a dozen tries or any number in between or more... AND here is when it crashes, even though it is rare.

Random crashes: Happen rarely, and only when trying to invoke "do not download." And, no I did not save the crash log, and know I should have, sorry. But no, I am not going to install yet again, to make it happen. :) Note that the crash did not cause Deluge to exit, it only gives the apport message etc..

I have not had any success with any version latter than 1.3.1.2. Any version after that does not work right on my machine as bizarre things occur.

Xubuntu Xenial 16.04.x running GTK 3.20 from Gnome stable ppa and pinned to version 3.20, and XFCE desktop.

comment:4 Changed 15 months ago by Udasomu_Shakerabu

As far as I'm concerned, I had the priority bug with 1.3.14, I applied only the patch from [cc69c9c85b7e1] that was mentioned in bug #2990, and everything is fine now, including for existing torrents.

Prods, just to clarify: there is no fixed 1.3.14 version published. The fix will be published in version 1.3.15. Are you really using the latest revision from Git, or patching this specific bug?

(I'm using libtorrent-rasterbar-1.0.11 and python-2.7.12 on Gentoo GNU/Linux).

comment:5 Changed 14 months ago by Prods

Greetings:

Been using 1.3.15 all day and the problems I have been having with 1.3.13 - 14 appear to be fixed! Thank you very much for your hard work :)

comment:6 Changed 14 months ago by Cas

  • Milestone changed from needs verified to 1.3.15
  • Resolution set to Fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.