#3017 closed bug (Duplicate)

Error adding Host

Reported by: keschrich Owned by:
Priority: minor Milestone: needs verified
Component: GTK UI Version: 1.3.14
Keywords: Cc:

Description

I have a headless deluge server (1.3.14), and am trying to connect to it from my Ubuntu machine where I have Deluge 1.3.14 installed.

I enter all the details on the Add Host screen, and click add and get the following error: "Unterminated string starting at: line 8 column 7 (char 150)".

The Add Host window closes and I am back at the Connection Manager window. The host I just attempted to add shows up in the list with a red status icon. I cannot close the window using the Close button, but it closes if I hit the X. Once closed, I can return to the connection manager, and the status icon for the host turns green and I can connect to it.

Further complicating things, the host is not saved when I exit deluge- so the next time I run the deluge client I have to do the above again.'

Attachments (1)

Screenshot from 2017-04-04 16-03-12.png (12.2 KB) - added by keschrich 13 months ago.
Screen shot of Add Host Error

Download all attachments as: .zip

Change History (6)

Changed 13 months ago by keschrich

Screen shot of Add Host Error

comment:1 Changed 13 months ago by keschrich

When I run deluge-gtk from a terminal, the following output appears:

[ERROR   ] 16:15:07 config:390 Unterminated string starting at: line 8 column 7 (char 150)
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/deluge/config.py", line 388, in load
    self.__config.update(json.loads(data[start:end]))
  File "/usr/lib/python2.7/json/__init__.py", line 339, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python2.7/json/decoder.py", line 364, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.7/json/decoder.py", line 380, in raw_decode
    obj, end = self.scan_once(s, idx)
ValueError: Unterminated string starting at: line 8 column 7 (char 150)

comment:2 Changed 13 months ago by keschrich

Solved by clearing config directory.

comment:3 Changed 13 months ago by andar

It sounds like a corrupt config file then. Do you happen to have a copy of the old directory? Perhaps the config loader should handle this more gracefully by moving the bad file to foo.conf.corrupt and start a fresh config file.

comment:4 Changed 10 months ago by igitihi

I have the same problem (Linux 1.3.15). Deleting the config files doesn't help, problem persists.

comment:5 Changed 10 months ago by Cas

  • Resolution set to Duplicate
  • Status changed from new to closed

See #3079

Note: See TracTickets for help on using tickets.