Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#308 closed bug (WorksForMe)

opening a .torrent file from a browser opens a new gtkui

Reported by: danii Owned by: andar
Priority: minor Milestone:
Component: GTK UI Version: 0.9.02 (1.0.0_RC2)
Keywords: add torrent browser Cc:

Description

Deluge 0.6.0.0r3301

opening a .torrent file from a browser, in this case firefox 3, opens a new gtkui, I think deluge should check if there's a ui running and only if it doesn't exist open the torrent in the new ui, don't know if it is possible to open torrents directly for the console and web ui, if they are the ones being used but it would be a nice feature also I think only one ui of each type should be allowed to run per user, I don't see anyone wanting to use more than one ui at the same time

Change History (10)

comment:1 Changed 13 years ago by andar

This will only happen if DBUS is not available. Do you not have DBUS installed and running on your system?

comment:2 Changed 13 years ago by danii

yes it's installed and running:

danii@hemper ~ $ dbus-daemon --version
D-Bus Message Bus Daemon 1.1.20
danii@hemper ~ $ ps ux|grep dbus
danii     7949  0.0  0.0   3020   480 ?        S    Jun23   0:00 /usr/bin/dbus-launch --sh-syntax --exit-with-session
danii     7951  0.0  0.0   2260   868 ?        Ss   Jun23   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
[DEBUG   ] 03:37:40 dbusinterface:100 Processing args from other process: ['/tmp/Life.on.Mars.US.S01E01.PREAiR.DVDSCR.XviD-MEDiEVAL.[eztv].torrent']
[DEBUG   ] 03:37:40 dbusinterface:119 Attempting to add /tmp/Life.on.Mars.US.S01E01.PREAiR.DVDSCR.XviD-MEDiEVAL.[eztv].torrent from external source..
[DEBUG   ] 03:37:40 addtorrentdialog:185 Attempting to open /tmp/Life.on.Mars.US.S01E01.PREAiR.DVDSCR.XviD-MEDiEVAL.[eztv].torrent for add.
[DEBUG   ] 03:37:40 addtorrentdialog:204 Torrent already in list!

in this example although the torrent already exists the new gtkui still opens

comment:3 Changed 13 years ago by andar

I don't know what to say. I cannot reproduce this behaviour. On my system, if a gtkui is already running and i run another it simply exits after it detects the other gtkui's dbus session. And if you add another torrent to an existing session it just sends the dbus command to the existing session to add the torrent and then exits.

comment:4 Changed 13 years ago by markybob

what system is this? linux? which distro/release?

comment:5 Changed 13 years ago by danii

distro is gentoo, WM is XFCE 4, I'm going to update and see if the bug persists

comment:6 Changed 13 years ago by andar

Is this still an issue? Can we close?

comment:7 Changed 13 years ago by anonymous

  • Milestone 0.6.0 deleted

Milestone 0.6.0 deleted

comment:8 Changed 13 years ago by danii

yes this is still an issue in Deluge 0.9.01

comment:9 Changed 13 years ago by andar

  • Milestone set to 1.0.0
  • Resolution set to worksforme
  • Status changed from new to closed
  • Version changed from 0.6.0svn to 0.9.02 (1.0.0_RC2)

I think you need to start the system dbus daemon. This should be accomplished by running /etc/init.d/dbus start in Gentoo. I would suggest adding this service to your default runlevel.

comment:10 Changed 12 years ago by anonymous

  • Milestone 1.0.0 deleted

Milestone 1.0.0 deleted

Note: See TracTickets for help on using tickets.