Opened 3 years ago

Last modified 7 months ago

#3091 new bug

Proxy settings ignored

Reported by: aviau Owned by:
Priority: critical Milestone: needs verified
Component: Plugin Version: 1.3.15
Keywords: proxy Cc: deadlyknapsack@…, a.starr.b@…

Description

Hello,

Even with intentionally bad proxy settings, Deluge can still download/upload.

I was doing this to confirm that deluge was in fact using my proxy, but it looks like its not.

Note that I have configured the proxy from the Web UI.

I have restarted the daemon several times.

Change History (7)

comment:1 Changed 3 years ago by DeadlyKnapsack

  • Cc deadlyknapsack@… added
  • Keywords proxy added

Confirmed. This was reported over 5 years ago and is still not fixed. Bug #2149 is about the same and was reported to be solved in version 1.3.14, but it clearly isn't.

comment:2 Changed 3 years ago by aviau

Note that I have tested with the official Debian package for Deluge.

Currently, Debian has the following libraries versions:

  • python-libtorrent 1.1.1

comment:3 Changed 3 years ago by andrewsomething

  • Cc a.starr.b@… added

comment:4 Changed 3 years ago by andrewsomething

  • Cc a.starr.b@… added

comment:5 Changed 3 years ago by OpenDeluge

I encountered this problem in Deluge2.0. Even if SOCKS5 is forcibly stopped, it can still be downloaded and uploaded

Last edited 3 years ago by OpenDeluge (previous) (diff)

comment:6 Changed 9 months ago by whereupon

I do not experience this in 1.3.15. Refer to comment 41 on https://dev.deluge-torrent.org/ticket/2149

Is the distinction non-authenticated socks5?

comment:7 Changed 7 months ago by John007

  • Component changed from Unknown to Plugin

Confirming and verifying that this is still a bug. This case is already opened at https://dev.deluge-torrent.org/ticket/2149

It would be very beneficial to hear back from the developers on this case.

Thank you so much :)

Note: See TracTickets for help on using tickets.