Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#3093 closed bug (WontFix)

Speed regulation ignored.

Reported by: loput Owned by:
Priority: minor Milestone: not applicable
Component: libtorrent Version: 1.3.15
Keywords: Cc:

Description

When download speed limit is set to be more than about 4100KB/s, it gets completely ignored and speed is maxed out. Even after setting it back to 4100, it's ignored until deluge is restarted.

Client: 1.3.15

libtorrent: 1.1.4.0

Linux 4.11.9-1-ARCH #1 SMP PREEMPT x86_64

Attachments (2)

deluge_2017-09-11_14-49-34.png (167.7 KB) - added by aariii 3 years ago.
Settings window
chrome_2017-09-11_14-54-28.png (40.4 KB) - added by aariii 3 years ago.
Status bar

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by aariii

Settings window

Changed 3 years ago by aariii

Status bar

comment:1 Changed 3 years ago by aariii

I'm seeing the same behavior with it ignoring the set download limit.

I've attached a couple of screenshots to demonstrate.

deluge-daemon: 1.3.15-2.fc26 libtorrent: 1.1.2-3.fc26 Linux 4.12.9-300.fc26.x86_64 #1 SMP x86_64

comment:2 Changed 3 years ago by egorkeke

Yes, there is such error :-(

Deluge 1.3.15 + libtorrent-rasterbar9 1.1.4

In this Deluge 1.3.15 + libtorrent-rasterbar9 1.1.1.0 everything is fine

Very prevents. Torrent scores all channel and it is impossible to work normally on the Internet :-(

Last edited 3 years ago by egorkeke (previous) (diff)

comment:3 Changed 3 years ago by ElectronicWar

  • Component changed from Unknown to libtorrent
  • Milestone changed from needs verified to not applicable
  • Resolution set to WontFix
  • Status changed from new to closed

Deluge 1.3 is not fully compatible with libtorrent 1.x due the age of its codebase. The recommended version is the latest 0.16.x release.

libtorrent 1.0.x seems to work mostly, too, but not sure about the speed limit and it's not tested as well. Either wait for Deluge 2.0 or downgrade libtorrent.

comment:4 follow-up: Changed 3 years ago by egorkeke

I do not argue. Just such a version in Debian Sid :-( A stable release Debian Deluge 1.3.13+git20161130.48cedf63-3 + libtorrent-rasterbar9 1.1.1.0 ie it turns out is not very good :-(

Sorry for the English. I use a translator. In any case, thank you.

comment:5 in reply to: ↑ 4 Changed 3 years ago by ElectronicWar

Replying to egorkeke:

I do not argue. Just such a version in Debian Sid :-( A stable release Debian Deluge 1.3.13+git20161130.48cedf63-3 + libtorrent-rasterbar9 1.1.1.0 ie it turns out is not very good :-(

Sorry for the English. I use a translator. In any case, thank you.

You can download previous 0.16.x package from Jessie repository at https://packages.debian.org/jessie/libtorrent-rasterbar7

I use this for my setup running debian-testing. I recommend to build Deluge from source on Debian. http://dev.deluge-torrent.org/wiki/Installing/Source#DebianUbuntuDependencies

Last edited 3 years ago by ElectronicWar (previous) (diff)

comment:6 Changed 3 years ago by egorkeke

Wanted to collect, but apparently did not happen. https://pastebin.com/KXyXEG7Z (Debian stretch + chroot)

Will have to use the "stable" version libtorrent-rasterbar9 1.1.1.0

Note: See TracTickets for help on using tickets.