Opened 13 years ago

Closed 12 years ago

#313 closed bug (Fixed)

Port forwarding not working on 0.6.0svn

Reported by: smbm Owned by: andar
Priority: major Milestone:
Component: Core Version: 0.6.0svn
Keywords: Cc:

Description

It's pretty much all in the title.

Working under 0.5.9.3 and prior but not under 0.6.0svn.

A show stopper for me unfortunately.

Other than that it's looking really good. Thanks for all the work devs

Change History (8)

comment:1 Changed 13 years ago by andar

Could you please elaborate?

comment:2 Changed 13 years ago by smbm

Hi

Sorry, I'm not sure I know how.

What would you like me to do?

I'm not really up on network stuff so I don't know how to debug this.

So far all I know is that it doesn't work.

I'm happy to help in whatever way I can though.

comment:3 Changed 13 years ago by andar

What do you mean by port forwarding? UPNP? NATPMP? If so, what kind of router are you using? Or are you simply trying to port forward on your router?

comment:4 Changed 13 years ago by smbm

Sorry, I see what you mean now UPNP is not working on my networks Netgear DG834G.

Sadly our network admin won't let us manually forward points so everyone on our network had to use UPNP.

comment:5 Changed 13 years ago by joose

Same problem hier, using Linksys router with dd-wrt firmware, but the i bypass it by using manually a program that sends the router the upnp-stuff.

comment:6 Changed 13 years ago by andar

Could you try rebuilding Deluge with "-DTORRENT_UPNP_LOGGING" added to the _extra_compile_args list in setup.py .. After you run with this build there should be a upnp.log created in the working directory -- please attach it to this ticket.

comment:7 Changed 13 years ago by arvid@…

maybe the upnp logging should be a runtime switch, to make it easier for people to generate it and help us fix the problems.

comment:8 Changed 12 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

Fixed [3712]

Note: See TracTickets for help on using tickets.