Opened 12 months ago

Last modified 12 months ago

#3191 new bug

Some errors in console-UI.

Reported by: mhertz Owned by:
Priority: minor Milestone: needs verified
Component: Console UI Version: develop
Keywords: Cc:

Description

When trying to delete a file in console-UI, it lists as deleted, but upon restarting daemon/client it's still there and i've tested it with several torrents, and only is an issue with git-develop. I think it has been like that for long, I just didn't notice as only did quick tests and not full-time.

Also, I love the new globbing functionality of the console-UI, as before it was great that we could use some front-letters, but sometimes, then several torrents starts with e.g. 'www.torrentsite.com - foo bar', which made it impractical, but now we can use 'rm -c *foo*'. However, this works fine usually, but in the previous example, it didn't work, e.g. I tried 'rm -c *ren*' and it didn't work, but did work with *foo*. Well, the example was this here:

https://tpb.tw/torrent/19750349/Mama.June-From.Not.To.Hot.S02E01.1080p.HEVC.x265-MeGusta

(Please delete link when finished with ticket), which has such a 'www*' heading, and when I tried that 'rm -c *ren*' it didn't work, and I needed to use chars from main-title for it to work, and then it said 'deleting "maintitle"' as if the torrent didn't had that www naming in front??? It maybe uses link name instead?Still it didn't delete it as per the report above, but that above is the same with everything, e.g. the ipmagnet link etc, none gets deleted for real and exist upon restart.

Lastly, the help text states you can change priority of a file in file-details with enter, and i've tried every key there is, with and without marking first, and I cannot change priority. I was trying to see if I could exclude a file through this, like it's done with rtorrent, but couldn't get it to work/show-up even.

Lastly, when a torrent isn't started downloading yet and waits for peers, e.g. can be tested with ipmagnet link: http://ipmagnet.services.cbcdn.com/

Then when pressing right-arrow to go to file-details, then unhandled errors are splattered over screen continually. I had updated to build-99 beforehand, so your unhandled deferred fix was included in the test.

Btw, if you maybe could consider making the console-UI autologin like it used to with localhost, as else non-interactive mode always needs everytime 'deluge-console "connect localhost ; info"' instead of just 'deluge-console info'

Thanks alot in advance!

Change History (1)

comment:1 Changed 12 months ago by mhertz

Latest build, now e.g. the linked magnet works with 'rm -c *ren*', but still comes back after restarting deluged, so not deleted. I had downloaded some of the torrent when 'rm'ed it, as I believe I reported previously that this only happened with files not started yet, but with this that's not true.

The last part about needing 'connect' when run non-interactively is only for 'rm' command no else commands - isn't that a bug?

Thanks in advance!

Note: See TracTickets for help on using tickets.