Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#3231 closed bug (WontFix)

Changing priority behaves strangely.

Reported by: loput Owned by:
Priority: major Milestone: 1.3.16
Component: Unknown Version: 1.3.15
Keywords: gtk web ui Cc:

Description

It's difficult to describe. It's all shown in the video - https://streamable.com/8zc6r

Client: 1.3.15

libtorrent: 1.1.11.0

Linux 4.20.0-arch1-1-ARCH x86_64

Change History (6)

comment:1 Changed 3 years ago by kripjj

I have this problem too with the web interface.

deluge: 1.3.15

libtorrent: 1.1.12.0

Linux version 4.9.125-linuxkit (gcc version 6.4.0 (Alpine 6.4.0) )

In the chrome browser dev console, these errors are occuring when I try to change the priority of a file or folder:

deluge-all.js:160 Uncaught TypeError: e.setColumnValue is not a function
    at constructor.<anonymous> (deluge-all.js:160)
    at Object.each (ext-base.js:7)
    at L.success (deluge-all.js:160)
    at constructor._onSuccess (deluge-all.js:1120)
    at Ext.data.Connection.handleResponse (ext-all.js:7)
    at f (ext-base.js:7)
    at m (ext-base.js:7)
    at ext-base.js:7
Last edited 3 years ago by kripjj (previous) (diff)

comment:2 Changed 2 years ago by zjeffer

I have the same problem, also on linux:

Deluge: 1.3.15

libtorrent: 1.1.12.0

Linux: 5.0.13-arch1-1-ARCH

comment:3 Changed 2 years ago by int3l

  • Keywords gtk web ui added

comment:4 Changed 2 years ago by Cas

  • Resolution set to WontFix
  • Status changed from new to closed

This is a problem with changes in libtorrent 1.1 file priority handling. The only solution is to use libtorrent 1.0 with Deluge 1.3. I'm afraid that this will not be fixed in 1.3 however it was fixed in 2.0: [6655fe67c37].

Last edited 2 years ago by Cas (previous) (diff)

comment:5 Changed 2 years ago by PukeMonster

Sorry, what? WontFix?? Are you serious?

So deluge 1.3.x series is absolutely finished now then? You're stopping all development and bugfixes on 1.3? Because if you don't fix this, you might as well throw 1.3 in the bin. It is completely unusable now.

It is just not good enough to say the problem is in libtorrent 1.1, so we can't fix deluge.

I've been usign Deluge for as long as I can remember, and i had two reasons for using it:

1) it works

2) it works well

Deluge now fails both of those tests.

This bug has to be fixed, or there is no point doing any more work on Deluge, at all.

Please re-open this bug, and fix the issue.

I can think of several possible ways to move forward:

1) Get it fixed in libtorrent. If they're the cause of the issue. How are they allowed to just completely change the way their priorities work if it is going to break clients like Deluge? They shouldn't be able to make changes like that unless they do it in libtorrent 2.0

2) You say the only solution is to use libtorrent 1.0 - so... use libtorrent 1.0!

If libtorrent aren't going to fix this issue in 1.1+, then, 1.1+ is unusable, and you need to go back to using libtorrent 1.0. Please advise how to do this.

Eg, for Windows, pls advise:

1) What was the last version of Deluge which used libtorrent 1.0 and thus actually *works*.

2) is it possible to get libtorrent 1.0 for Windows and drop it into the Deluge install folder to overwrite the garbage 1.1, and have things work again?

3) Will you (pls) package the current and future releases of Deluge 1.3.x, with a working libtorrent 1.0?!

4) If all of this is too hard, is Deluge 2.x going to be available for Windows anytime soon, and is it going to be usable? I have already switched to qBittorrent and if Deluge doesn't become usable again *soon*, I doubt if i will *ever* bother coming back.

comment:6 Changed 2 years ago by PukeMonster

FWIW, I've just tried going back to 1.3.12, and this appalling bug is not present in deluge-1.3.12-1-win32-py2.7-setup.exe

As far as I'm concerned, later versions of Deluge may as well not even exist, until this bug is fixed.

So it's up to you. Fix this bug, or don't fix it. I don't care anymore. But, you might as well be aware that if you don't fix this bug, everything else you're doing on 1.3.16+ is utterly pointless.

Carry on.

Note: See TracTickets for help on using tickets.