Opened 2 years ago

Closed 2 years ago

#3280 closed bug (Fixed)

Label plugin unable to reopen label options

Reported by: Cas Owned by:
Priority: minor Milestone: 2.0.4
Component: Plugin Version: 2.0.0
Keywords: Cc:

Description

From a forum user: https://forum.deluge-torrent.org/viewtopic.php?f=7&t=55394

Attached is a short screen recording to show how the context menu behavior looks like. After I close the first modal, the context menu opens, but any click on "Label Options" does nothing. The functionality of the add or remove label entries is intact. In the process of this testing I also found the attached console error about it. I'm wondering why I didn't see that the first time around.

Attachments (2)

ZK5Yn2g.png (9.9 KB) - added by Cas 2 years ago.
CyP1cOJ.gif (63.5 KB) - added by Cas 2 years ago.

Download all attachments as: .zip

Change History (5)

Changed 2 years ago by Cas

Changed 2 years ago by Cas

comment:1 Changed 2 years ago by Cas

  • Milestone changed from needs verified to 2.0.4

From my quick testing it looks like clicking the dialog X button or pressing the Esc key results in the dialog unable to re-open and a similar console error:

TypeError: me.dom is undefined ext-all-debug.js:8073:15
    ExtJS 4
    show http://localhost:8112/js/label/label.js:398
    onLabelOptionsClick http://localhost:8112/js/label/label.js:609
    ExtJS 5
        fire
        fireEvent
        onClick
        onClick
        h

Using the OK or Cancel buttons works fine.

comment:2 Changed 2 years ago by DjLegolas

This happens with the add button too.

And I found the cause, and fixed it. PR: 252.

Last edited 2 years ago by DjLegolas (previous) (diff)

comment:3 Changed 2 years ago by Cas

  • Resolution set to Fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.