Opened 5 years ago

Closed 5 years ago

#3284 closed bug (Upstream)

Opensuse No module named 'gi.pygtkcompat'

Reported by: Cas Owned by:
Priority: minor Milestone: not applicable
Component: Packaging Version: 2.0.0
Keywords: Cc:

Description (last modified by Cas)

From forum: https://forum.deluge-torrent.org/viewtopic.php?f=7&t=55400&p=229928&hilit=pygtkcompat#p229928

a packaging problem on opensuse, pygtkcompat has been deleted from python3-gobject package which breaks twisted.

Traceback (most recent call last):
File "/usr/bin/deluge-gtk", line 11, in <module>
load_entry_point('deluge==2.0.3', 'gui_scripts', 'deluge-gtk')()
File "/usr/lib/python3.6/site-packages/deluge/ui/gtk3/__init__.py", line 63, in start
Gtk().start()
File "/usr/lib/python3.6/site-packages/deluge/ui/gtk3/__init__.py", line 43, in start
from .gtkui import GtkUI
File "/usr/lib/python3.6/site-packages/deluge/ui/gtk3/gtkui.py", line 27, in <module>
from twisted.internet import defer, gtk3reactor
File "/usr/lib64/python3.6/site-packages/twisted/internet/gtk3reactor.py", line 26, in <module>
from twisted.internet import gireactor
File "/usr/lib64/python3.6/site-packages/twisted/internet/gireactor.py", line 78, in <module>
import gi.pygtkcompat
ModuleNotFoundError: No module named 'gi.pygtkcompat'

Change History (2)

comment:1 Changed 5 years ago by Cas

  • Description modified (diff)

comment:2 Changed 5 years ago by Cas

  • Milestone changed from 2.0.4 to not applicable
  • Resolution set to Upstream
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.