Opened 10 months ago

Last modified 6 months ago

#3294 new bug

Tracker status: Invalid Argument

Reported by: Twisted- Owned by:
Priority: major Milestone: 2.0.4
Component: Core Version: 2.0.3
Keywords: Invalid argument Cc:

Description

Recently upgraded from Deluge 1.3.x to 2.0.3 and since then I've noticed some of the trackers give "Tracker Status: Error: Invalid argument".

This also happens when I add new torrents of the same trackers.

I've tried running Deluge with debugging enabled but couldn't find any errors related to this. If you need any more logs or information let me know.

Change History (13)

comment:1 Changed 9 months ago by efhalo

I have the same problem. Deluge 2.0.3 Debian sid, python-libtorrent: 1.1.13

comment:2 Changed 8 months ago by Twisted-

This problem seems to go away after upgrading to python3-libtorrent 1.2.2.0. Unfortunately this bring about a bunch of errors about "Address family not supported by protocol" but those don't seem to stop it from downloading/seeding.

comment:3 Changed 7 months ago by armagedon

having the same problem. tried to follow this step : https://dev.deluge-torrent.org/wiki/Building/libtorrent but not worked for me. can you please describe how to getting work ?

comment:4 Changed 7 months ago by Twisted-

https://launchpad.net/~libtorrent.org/+archive/ubuntu/1.2-daily

I added the PPA as described in the link above. That should get you a version that worked for me.

comment:5 Changed 7 months ago by armagedon

thank you for your quick response. I've successfully updated the lib to version 1.2.1 via given ppa. but I'm getting another Error now :

Error: Address family not supported by protocol

comment:6 Changed 7 months ago by Twisted-

I was getting the same error, although that particular error doesn't stop it from actually working. I assume it has something to do with IPv6.

On a different note, the last python3-libtorrent update broke deluge again. Couldn't get it started anymore.

I downgraded back to the Ubuntu repo version of python3-libtorrent (1.1.11). Of course the invalid argument problem came back. One tracker gave me a more useful error message though: "error port 0 not allowed". After checking my settings and changing my incoming port, applying and changing it back to the original (and applying again) both the error "port 0 not allowed" and the "invalid argument" errors went away. So you might want to try that with the original library.

comment:7 Changed 7 months ago by armagedon

I found out by enabling randim port the error disappear

comment:8 Changed 7 months ago by bairrd

Is there any way to get around this problem and maintain a static port number? My router doesn't allow for using a random port.

comment:9 Changed 7 months ago by Twisted-

As far as I understand the problem, there is an issue while upgrading causing Deluge to advertise port 0 as the port to be used.

Changing the port and setting it back to the original solved it for me. Changing it to use a random port solves it for armagedon.

Sounds to me like they both do the same thing though, make sure that Deluge advertises an actual port and not 0.

comment:10 Changed 7 months ago by bairrd

I've tried changing the port and changing it back, and I still get the "Invalid Argument" error, and setting it to a random port does not work for me given my router.

comment:11 Changed 7 months ago by bairrd

Okay, changing the ports, changing it back, and then rebooting my system worked for me.

comment:12 Changed 7 months ago by bairrd

Every new torrent I add, I have to go through changing the port, channging it back, and rebooting. Hopefully this issue gets fixed so I don't have to do this every day.

comment:13 Changed 6 months ago by Cas

  • Component changed from Unknown to Core
  • Milestone changed from needs verified to 2.0.4
Note: See TracTickets for help on using tickets.