Opened 5 years ago

Closed 22 months ago

#3297 closed bug (WontFix)

deluged pid adds extra number

Reported by: fdge00 Owned by:
Priority: minor Milestone: needs verified
Component: Unknown Version: 2.0.3
Keywords: Cc:

Description

The pid file gets created with the correct Process ID but adds extra numbers ('50204')

# cat $deluged_confdir/deluged.pid
78614;50204

FreeBSD 11.2-RELEASE-p4 used python3.6 -m pip install --upgrade deluge to install.

Change History (4)

comment:1 Changed 5 years ago by fdge00

launch using:

/usr/local/bin/python3.6 /usr/local/bin/deluged --config $deluged_confdir

comment:2 Changed 5 years ago by fdge00

It is the daemon_port that gets appended to the pid file.

comment:3 Changed 2 years ago by deaddrop9

Comments in code suggest this is by design, pid and port are used to check at startup if another deluge server process is running.

comment:4 Changed 22 months ago by Cas

  • Resolution set to WontFix
  • Status changed from new to closed

Yes that is an internal file but can use pidfile option:

 -P, --pidfile <pidfile>        Pidfile to store the process id
Note: See TracTickets for help on using tickets.