Opened 4 years ago

Closed 7 months ago

#3339 closed bug (Fixed)

Runtime error in Windows when maximizing

Reported by: cinderblock Owned by:
Priority: major Milestone: 2.1.2
Component: Unknown Version: 2.0.3
Keywords: Cc:

Description

If you maximize the Deluge GTK window in Windows (only tested in Thin client), a runtime error occurs.

Program: ...\cairo.dll
File: cairo-surface.c
Line: 955

Expression: CAIRO_REFERENCE_COUNT_HAS_REFERENCE(&surface->ref_count)

If you "ignore", the interface seems to work, but breaks when doing anything useful.

Attachments (2)

Untitled.png (8.7 KB) - added by cinderblock 4 years ago.
Error window
crash.png (11.0 KB) - added by MrNerdHair 3 years ago.
Another error; this time from Win10 2004, using deluge-2.0.3-lt1.2.10-boost1.74-py3.8.5-ossl1.1.1g-GTK3.24.23.exe from https://github.com/petersasi/deluge2-win-build.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by cinderblock

Error window

Changed 3 years ago by MrNerdHair

Another error; this time from Win10 2004, using deluge-2.0.3-lt1.2.10-boost1.74-py3.8.5-ossl1.1.1g-GTK3.24.23.exe from https://github.com/petersasi/deluge2-win-build.

comment:1 Changed 2 years ago by Cas

This might be related to using the pieces progress bar, can you try disabling that

comment:2 Changed 2 years ago by Cas

The Stats plugin also uses cairo so that might also be a cause of crash here

comment:3 Changed 2 years ago by Cas

  • Milestone changed from needs verified to 2.1.0

I am going to put this on the 2.1 milestone but I suspect it will need fixing upstream in cairo since seems isolated to Windows

comment:4 Changed 22 months ago by Cas

  • Milestone changed from 2.1.0 to 2.1.1

Ticket retargeted after milestone closed

comment:5 Changed 8 months ago by Cas

I have a potential fix but not tested it on Windows to confirm

https://github.com/deluge-torrent/deluge/pull/431

comment:6 Changed 8 months ago by mhertz

Awesome, thanks Cas, I tested your PR working in my test win10 VM, thanks! I actually tried when you initially posted, but couldn't reproduce then, but now searched my older posts and recalled it doesn't happen anymore unless overriding default GTK_CSD=0, so I did, and with window not maximized I resized it through dragging left border little to left, and immediate crash without your fix and fine with it, atleast in testing 3 tries each with/without, and both stats and pieces enabled in prefs. Thanks again!

comment:7 Changed 7 months ago by Cas

  • Milestone changed from 2.1.1 to 2.1.2
  • Resolution set to Fixed
  • Status changed from new to closed

Excellent thanks for testing and confirming!

Note: See TracTickets for help on using tickets.