Opened 3 months ago

#3396 new feature-request

Support for GeoIP2 databases

Reported by: cross Owned by:
Priority: minor Milestone: needs verified
Component: Unknown Version: 2.0.0
Keywords: Cc:

Description

There is no active legacy GeoIP module available for FreeBSD. Other operating systems may face similar, as it has been legacy for years.

Any chance we could change the GeoIP calls in the deluge project to use the newer GeoLite2 databases?

https://dev.maxmind.com/geoip/geoip2/geolite2/

It would require some testing, as they don't claim full support for the free GeoLite2 databases, rather than their licensed GeoIP2 databases, but. The code changes shouldn't be too hard I wouldn't think.

Change History (0)

Note: See TracTickets for help on using tickets.