Opened 2 years ago

Closed 12 months ago

#3458 closed bug (Upstream)

"move completed to" doesn't work

Reported by: MotoFckr9k Owned by:
Priority: minor Milestone: needs verified
Component: libtorrent Version: 2.0.3
Keywords: move_storage Cc: imagenoir@…

Description

When a torrent finishes, it doesn't get moved to the "completed" path anymore. This worked fine at some point. Pretty sure it worked fine before in this same version. The path is writable and the log doesn't say anything.

Change History (8)

comment:1 Changed 2 years ago by MotoFckr9k

It turns out that this doesn't happen to every torrent. I started two and only one of them got moved.

comment:2 Changed 2 years ago by demonxl

This is a libtorrent bug. Possibly fixed in 1.2.11 https://github.com/arvidn/libtorrent/releases
It didn't work for me with libtorrent 1.2.9(Debian Bullseye).
With version 1.2.12 it worked.

comment:3 Changed 21 months ago by nop666

Confirmed

comment:5 Changed 21 months ago by nop666

  • Cc imagenoir@… added

comment:6 Changed 21 months ago by nop666

  • Component changed from Unknown to libtorrent
  • Keywords move_storage added

comment:7 Changed 20 months ago by MotoFckr9k

Issue is fixed in Debian Buster and Debian Bullseye. A maintainer incuded the upstream patch that apparently fixes the issue.

comment:8 Changed 12 months ago by gazpachoking

  • Resolution set to Upstream
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.