Opened 14 years ago

Closed 13 years ago

#348 closed bug (Duplicate)

Deluge 1.0 rc8 cpu usage

Reported by: sotiriss@… Owned by: andar
Priority: major Milestone:
Component: Core Version: 1.1.0
Keywords: Cc:

Description

When i installed Deluge 1.0 rc2, i am having problems with my cpu usage. With the 0.5.9.3 version everything was ok (about 4-5% of my cpu steadily), but now i have sudden increasings of my cpu, which may reach 100% . (I use Hardy)

Attachments (1)

output2.jpg (183.8 KB) - added by Dennis J. <dennisj@…> 14 years ago.
Graph of a profiling session

Download all attachments as: .zip

Change History (14)

comment:1 Changed 14 years ago by andar

  • Component changed from 0.5.x to core
  • Owner changed from markybob to andar

Yes, this is known and the cause hasn't yet been identified. If you can, please profile the deluged when you experience this issue and attach the data.

comment:2 Changed 14 years ago by sotiriss@…

How can I profile the deluged? Thank you

comment:3 Changed 14 years ago by anonymous

I'm seeing the same thing. I tried profiling with oprofile but that didn't give me any useful data because I can't seem to isolate the information for "deluge" or "deluged" because these are not proper processes (because they are run as python scripts). I see this fairly often so I could pinpoint the problem quickly but I need some info how to profile deluge properly.

comment:4 Changed 14 years ago by andar

You have to specify libtorrent.so, which usually lives somewhere like: /usr/lib/python2.5/site-packages/deluge-0.9.02-py2.5-linux-i686.egg/deluge/libtorrent.so

comment:5 Changed 14 years ago by anonymous

I see this a lot as well. But I've never profiled a python program before. Can you provide specific steps to follow to debug it? I'm also on Ubuntu Hardy.

comment:6 Changed 14 years ago by matter.grey@…

Okay, I'm the second anonymous poster that just posted here. I kept trying, and I had a bit more luck. However, I'm now stuck again. I lack symbols for libtorrent. Is there a debug package anywhere that I can download that contains symbols or a map?

Changed 14 years ago by Dennis J. <dennisj@…>

Graph of a profiling session

comment:7 Changed 14 years ago by andar

  • Milestone set to 1.0.0
  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed with [3680]

comment:8 Changed 14 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from Deluge 1.0 rc2 cpu usage to Deluge 1.0 rc8 cpu usage
  • Version changed from 0.9.02 (1.0.0_RC2) to 0.9.08 (1.0.0_RC8)

same problem here for me with 1.0.0_rc8.

comment:9 follow-up: Changed 14 years ago by andar

  • Resolution set to fixed
  • Status changed from reopened to closed

Use boost 1.34 or 1.36, boost 1.35 contains the cpu spike bug.

comment:10 Changed 14 years ago by anonymous

  • Milestone 1.0.0 deleted

Milestone 1.0.0 deleted

comment:11 in reply to: ↑ 9 Changed 13 years ago by anonymous

  • Version changed from 0.9.08 (1.0.0_RC8) to 1.1.0

Replying to andar:

Use boost 1.34 or 1.36, boost 1.35 contains the cpu spike bug.

I am seeing this CPU spike issue as well. Using libboost 1.34.1 (as found in Ubuntu repos) and Deluge 1.1.1 (as found in the Intrepid PPA).

comment:12 Changed 13 years ago by scott.armitage

  • Resolution fixed deleted
  • Status changed from closed to reopened

Sorry, forgot to change status. mail@…

comment:13 Changed 13 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.