Opened 3 years ago

Last modified 2 years ago

#3484 new bug

deluge-gtk 2.0.3 thin client not showing all torrents

Reported by: tremby Owned by:
Priority: major Milestone: needs verified
Component: GTK UI Version: 2.0.3
Keywords: Cc:

Description

I have deluged 2.0.3 running on machine A, which is headless. It has some 750 torrents seeding. They were restored after an upgrade from the older version of Deluge by running the script described in https://forum.deluge-torrent.org/viewtopic.php?t=55508&start=10 -- mentioning this in case it is a clue.

If I run deluge-console on machine A I see all torrents.

I add torrents to Deluge via Flexget, and this works fine.

The problems appear when I run deluge-gtk 2.0.3 from machine B and connect to the deluged running on machine A. It shows 0 torrents, though oddly under "labels" in the sidebar, the "All" label shows the full 750-something number of torrents. If I click it, no data appears. "All" in the top of the sidebar (under "trackers") shows 0.

I found that if I add a torrent via deluge-gtk it *does* show up.

If I then look in deluge-console on machine A I see all torrents including the 750-something *and* the newly added one.

What is going on here?

I should also mention that I see a lot of twisted errors (3 arguments passed but expected 1 or 2) in the console if I run deluge-gtk from the console. I searched around for this and as far as I can gather it's a known bug and only affects logging so can be ignored. Mentioning it all the same. I didn't see anything else surprising in the logs.

Change History (3)

comment:1 Changed 2 years ago by Cas

This is very odd, can you test with latest release?

comment:2 Changed 2 years ago by gazpachoking

Is this something to do with deluge users? What user is your Flexget instance connecting as, how about your gtk instance?

comment:3 Changed 2 years ago by tremby

Ah, that must be it. Thank you.

I'm running deluge-console with no special arguments or configuration, and I see once it's started it has connected as localclient@127.0.0.1:...

On the other machine, with deluge-gtk, I'm connecting with a deluge user.

I don't think I did anything differently in the past, so I am guessing that this is a change which came along with Deluge 2 -- that the non-"localclient"-user can only see torrents they added, whereas "localclient" can see everything.

So I guess I need to either have flexget and deluge-console connect as a deluge user, or stop using the deluge user and use the main user everywhere.

Note: See TracTickets for help on using tickets.