Opened 7 months ago

Closed 6 months ago

#3497 closed bug (Fixed)

"stop seed at ratio" feature fails to trigger when not logged into Web UI or not connected with Deluge-GTK

Reported by: glodomorrapl Owned by:
Priority: major Milestone: 2.1.0
Component: Core Version: 2.0.3
Keywords: daemon, seed limit, stop seed at ratio, web ui, gtk Cc: glodomorrapl@…, traian.coza@…

Description

i have a torrent, which i set "stop seed at ratio" to 2.

what i expected to happen: as soon as the torrent exceeds the ratio of 2, it's automatically stopped regardless of whether or not I'm currently logged into the Web UI

what happened: i log into the Web UI just to see the torrent exceed the upload ratio by multiple amounts of the value I set - the torrent was still active, and it paused after about a second or two after I logged into the Web UI

i think priority of this bug would be "major" at least, as the failure of that feature may potentially result in exceeding upload quotas

Change History (4)

comment:1 Changed 7 months ago by tcoza

I have the exact same problem. This doesn't seem to have anything to do with Web UI, tho. It would be the role of the Deluge Daemon to pause seeding torrents after they have reached a certain ratio, but it doesn't. The same thing happens when you use Deluge-GTK in Thin-Client mode, connected to a daemon. The torrent keeps seeding until you open Deluge-GTK, then it keeps going for about 1 second and pauses.

comment:2 Changed 7 months ago by tcoza

  • Cc traian.coza@… added
  • Component changed from Web UI to Core
  • Keywords daemon gtk added
  • Summary changed from "stop seed at ratio" feature fails to trigger when not logged into Web UI to "stop seed at ratio" feature fails to trigger when not logged into Web UI or not connected with Deluge-GTK

comment:3 Changed 6 months ago by gazpachoking

Okay, started looking in to this. I haven't fully confirmed yet, but it looks like with no clients connected, the cached status of the torrent keeps getting used for the stop ratio check. Once a client connects, it forces the cache to update, and the stop ratio check works properly.

comment:4 Changed 6 months ago by Cas

  • Milestone changed from needs verified to 2.1.0
  • Resolution set to Fixed
  • Status changed from new to closed

Thanks gazpachoking for fixing this!

Fixed in [8ff468378]

Note: See TracTickets for help on using tickets.